Mysql Connectivity Error after install mysqlnd


#1

I have the Easy Engine running on a server in DigitalOcean. Everything worked well, but after I installed the mysqlnd via “apt-get install php5-mysqlnd” I started having problems creating a new site with “ee create site abc.com.”

The easy engine creates the database, create the user, but can not give permission to the user.

LOG:

2015-10-06 15:21:56,803 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'create', 'abc.com.br', '--wpredis']
2015-10-06 15:21:56,803 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f8cf0a17588>
2015-10-06 15:21:56,808 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7f8cf0a176a0>
2015-10-06 15:21:56,810 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteCreateController object at 0x7f8cf0a17eb8>
2015-10-06 15:21:56,813 (INFO) ee : Initializing EasyEngine Database
2015-10-06 15:21:56,835 (INFO) ee : ^[[94mRedis is experimental feature and it may not work with all CSS/JS/Cache of your site.
You can disable it by changing cache later.
Do you wish to enable Redis now for abc.com.br?^[[0m
2015-10-06 15:21:59,551 (DEBUG) ee : ^[[95mSetting apt_packages variable for Nginx^[[0m
2015-10-06 15:22:01,651 (DEBUG) ee : ^[[95mFinding string SCRIPT_FILENAME to file /etc/nginx/fastcgi_params^[[0m
2015-10-06 15:22:01,652 (DEBUG) ee : ^[[95mSetting apt_packages variable for PHP^[[0m
2015-10-06 15:22:03,878 (DEBUG) ee : ^[[95mSetting apt_packages variable for MySQL^[[0m
2015-10-06 15:22:03,878 (DEBUG) ee : ^[[95mRunning command: mysqladmin ping^[[0m
2015-10-06 15:22:03,892 (DEBUG) ee : ^[[95mSetting apt_packages variable for Postfix^[[0m
2015-10-06 15:22:06,221 (DEBUG) ee : ^[[95mSetting packages variable for WP-CLI^[[0m
2015-10-06 15:22:06,222 (DEBUG) ee : ^[[95mRunning command: which wp^[[0m
2015-10-06 15:22:06,231 (DEBUG) ee : ^[[95mSetting apt_packages variable for redis^[[0m
2015-10-06 15:22:08,159 (DEBUG) ee : ^[[95mFinding string redis to file /etc/nginx/conf.d/upstream.conf^[[0m
2015-10-06 15:22:08,160 (INFO) ee : ^[[94mRunning pre-update checks, please wait...^[[0m
2015-10-06 15:22:08,160 (DEBUG) ee : ^[[95mchecking NGINX configuration ...^[[0m
2015-10-06 15:22:08,392 (INFO) ee : ^[[94mSetting up NGINX configuration        ^[[0m
2015-10-06 15:22:08,393 (DEBUG) ee : loading template file /usr/lib/ee/templates/virtualconf.mustache
2015-10-06 15:22:08,633 (DEBUG) ee : ^[[95mChecking generated nginx conf, please wait...^[[0m
2015-10-06 15:22:09,075 (INFO) ee : ^[[94m[^[[0mDone^[[94m]^[[0m
2015-10-06 15:22:09,076 (DEBUG) ee : ^[[95mCreating Symbolic link, Source:/etc/nginx/sites-available/abc.com.br, Dest:/etc/nginx/sites-enabled/abc.com.br^[[0m
2015-10-06 15:22:09,076 (INFO) ee : ^[[94mSetting up webroot            ^[[0m
2015-10-06 15:22:09,076 (DEBUG) ee : ^[[95mCreating Symbolic link, Source:/var/log/nginx/abc.com.br.access.log, Dest:/var/www/abc.com.br/logs/access.log^[[0m
2015-10-06 15:22:09,076 (DEBUG) ee : ^[[95mCreating Symbolic link, Source:/var/log/nginx/abc.com.br.error.log, Dest:/var/www/abc.com.br/logs/error.log^[[0m
2015-10-06 15:22:09,077 (INFO) ee : ^[[94m[^[[0mDone^[[94m]^[[0m
2015-10-06 15:22:09,467 (INFO) ee : ^[[94mDownloading Wordpress                 ^[[0m
2015-10-06 15:22:09,468 (DEBUG) ee : ^[[95mChanging directory to /var/www/abc.com.br/htdocs/^[[0m
2015-10-06 15:22:09,468 (DEBUG) ee : ^[[95mRunning command: wp --allow-root core download^[[0m
2015-10-06 15:22:10,553 (INFO) ee : ^[[94m[^[[0mDone^[[94m]^[[0m
2015-10-06 15:22:10,556 (INFO) ee : ^[[94mSetting up database           ^[[0m
2015-10-06 15:22:10,556 (DEBUG) ee : ^[[95mCreating database abc_com_br^[[0m
2015-10-06 15:22:10,563 (DEBUG) ee : ^[[95m^[[0m
2015-10-06 15:22:10,564 (DEBUG) ee : ^[[95mExceuting MySQL Statement : create database `abc_com_br`^[[0m
2015-10-06 15:22:10,566 (DEBUG) ee : ^[[95mCreating user abc_com_br^[[0m
2015-10-06 15:22:10,566 (DEBUG) ee : ^[[95mcreate user `abc_com_br`@`localhost` identified by ''^[[0m
2015-10-06 15:22:10,575 (DEBUG) ee : ^[[95mSetting up user privileges^[[0m
2015-10-06 15:22:10,577 (DEBUG) ee : ^[[95m(1045, "#28000Access denied for user 'root'@'localhost' (using password: YES)")^[[0m

#2

Some problem with permissions. Solved with mysql_secure_installation.


#3