My frontpage is taking around 30 minutes to reflect changes


#1

Hi All,

I’ve got my server setup with Nginx, fast-cgi, nginx purge and the wordpress helper and everything is running fantastically.

However I have a problem where the front page isn’t being refreshed when a new post goes live. It takes around 30 minutes before the new posts start showing on the page.

As a logged in user to wordpress I see the post go live instantly as I’m bypassing the cache but readers need a direct link to read the article.

I’ve changed my logging to show all info and I just did an update now and have the following 2017-05-04 05:42:06 | INFO | Function purgePost BEGIN === 2017-05-04 05:42:06 | INFO | Purging homepage ‘http://www.criticalhit.net/’ 2017-05-04 05:42:06 | INFO | - Purging URL | http://www.criticalhit.net/ 2017-05-04 05:42:06 | INFO | - - http://www.criticalhit.net/purge/ *** PURGED ***

So there appears to be no errors but the latest posts don’t show?

Any ideas?

Thanks, Gavin

[UPDATE] So after I posted this and enabled full logging the problem has magically disappeared. I’m not sure if it’s related to the change in logging as that’s all I changed but it is working now. So if you come across this as someone with the same problem maybe try that?


#2

Its for sure nothing related to the errorlog level.

Probably an issue with your local cache? Have you tried hard refreshing the browser’s page via ctrl+f5? Is this behavior occuring when using an icognito window too?

Also, are you sure that your theme “woohoo” is not including a caching mechanism built in?


#3

either do service php7.0-fpm restart or run ee clean --all


#4