More than 30 days left for certificate Expiry. Not renewing now


#1

Hi Friends!

I can not update my certificate:

Information about mysite.com: Nginx configuration wp wpredis (enabled) PHP Version 7.0 HHVM disabled SSL enabled SSL PROVIDER Lets Encrypt SSL EXPIRY DATE Sat Jun 24 17:21:00 MSK 2017

A month ago I moved to HTTPS. This worked well. But then the browsers began to talk about distrust of my Letsencrypt certificate.

I tried to update it manually: Sudo ee site update mysite.com --letsencrypt = renew

But I received the message: More than 30 days left for certificate Expiry. Not renewing now.

I took the advice of the community and did:

Service nginx start It did not help.

Export LC_ALL = "en_US.UTF-8" Export LC_CTYPE = "en_US.UTF-8" This also did not help.

Sudo apt-get update Sudo apt-get upgrade Service nginx stop / Opt / letsencrypt / letsencrypt-auto renew Service nginx start And it did not help.

And I also fixed the line in the “/var/spool/cron/crontabs/root” file: 0 0 * * 0 ee site update --le=renew --all 2> /dev/null # Renew letsencrypt SSL cert. Set by EasyEngine to 0 12 * * * ee site update --le=renew --all 2> /dev/null # Renew letsencrypt SSL cert. Set by EasyEngine It did not help too.

By the way, there is no file with the user name in the “/var/spool/cron/crontabs/” folder. This is normal?

Rebooting the server did not help either …

What did I do wrong? How can I enable certificate and get auto-updates?


#2

What’s the exact error message you see in your browser? Does it happens to everyone accessing your site or just you?


#3

I had to add

SHELL=/bin/sh
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

To the top of crontab.

This allowed cron to update LE certs and get mailbox sizes in vimbadmin. A users cron PATH is not inherently the same as that users. Not sure if this is bad practice security wise, but it works. You can also add

MAILTO="user@example.com"

And cron will email you a very satisfying message from ee when ssl is updated.

I also think if a cert is quite a bit outdated LE will refuse to update it. I think you have to turn it off in ee then dig into LE and delete it manually then let ee set it back up. That last part is from memory. Add those paths to cron I think that is what your dealing with.


#4