@mentions in media comments


#1

Hi guys

There was an rtmedia update a few days ago. With a new feature, you can now mention in comments but it does not work for me, do i have to change something in the settings?

Thanks for respone

Janick


#2

Hi Janick,

rtMedia’s “@mentions” feature is an extension of the same functionality provided by BuddyPress. To enable this functionality, you will need to ensure that the “Activity Streams” component from Settings > BuddyPress.

Once enabled, you will be able to mention any user on your site when you start typing their name.

I hope this clears your doubts.

Regards,

Joel Abreo


#3

Hi Joel

Thanks for your answer. In the rtmedia settings at buddypress, all buttons are “on”. I am able to mention the users, but i want to mention them also in a comment. So when i click on a uploaded media from an user, there comes a lightbox for like and comment the picture, in this comments i would like to mention, and this does not work, but it should, after the new rtmedia update.

This was the update:

4.2 [Nov 17, 2016]

NEW FEATURES

Albums will now display media count by default @mentions” in comments added to lightbox and single media page Added “Next” / “Previous” navigation links to single media page

Thanks for response :slight_smile:


#4

Hello again!

Just to confirm, “@mentions” is working in your Activity Feed, but not working in a Lightbox. If this is the case, this is probably a JavaScript related problem.

Can you check if the problem persists after hard refreshing your browser? You can also try clearing any caches that you might have set up on your website before you try again.

If the problem persists even after this, could you send your Debug Info? ( rtMedia > Support > Debug Info )

Let me know if once you make any progress.

Regards,

Joel Abreo


#5

Hi Joel

Still does not work, refreshed everything and cleared all the cache. :confused:

This is my debug info:

Home URL http://www.planet-of-fitness.com Site URL http://www.planet-of-fitness.com PHP 7.0.2 MYSQL 5.6.33 WordPress 4.6.1 BuddyPress 2.7.2 rtMedia 4.2 OS Linux Imagick Not Installed GD bundled (2.1.0 compatible) [php.ini] post_max_size 100M

Thank you :slight_smile:


#6

Hi @planetoffitness,

I can see the @mentioned members in media comment section. Check this screenshot of your website.


#7

Hi Joel

Im confused. It does not work for me, not in the activity stream (Pinnwand), and not in the picture of the media gallery of a user. I tested it with my admin profile AND with an normal user profile. Also on different browsers.

How did you do this??

Thanks


#8

Look…


#9

Hey Joel

It works now… but its strange, i had to clear the whole browser cache and history. Now every user has to do this before they can mention someone?

Thanks for your help!! :slight_smile:

by the way, how did you make the emoticons on this website? with a plugin?

Cheers


#10

Hi Janick,

This shouldn’t be necessary. We experienced no such issues during our development or testing, so your case might be a one-off. However, if any of your users face a similar issue, you now know how to fix it :wink:

I assume that you are asking about this coomunity.rtcamp.com website. We are using the Discourse discussion platform ( http://www.discourse.org/ ) that has emoji support built-in.

If you want to add emoji to your WP website, you should easily be able to do so with plugins or custom code.

Regards,

Joel Abreo


#11

Hi Joel

Thanks again for your support.

There are no good plugins for emojis, i tried nearly all of them… sometimes my site was crashed after i downloaded one of these. :open_mouth: Anyway, this is just optional…

Thanks and have a good time!


#12