Media Upload via Ajax


#1

Hello,

we have a problem with the media upload over Ajax. We are using this endpoint from your json-api https://rtmedia.io/docs/developers/json-api/#media-upload

It worked for us a long time, but since a few weeks we have problems.

Can you please help us?

We used the code in „testcall-jquery-current.txt“ since January 2016. But now we always get an error now, that the title is not set.

So we tried the code in „testcall-jquery-new.txt“. But here we get an incorrect response too, that our title is not set.

We tried a last one call with XHR and build the request as string („testcall-xhr.txt“). This call sends returns a successfull response, but the uploaded picture is empty.

Thank you very muchtestcall-jquery-current.txt (14.2 KB) testcall-jquery-new.txt (29.3 KB) testcall-xhr.txt (29.9 KB)


#2

Hello @dabiathlet,

We are looking into the issue. It will be fixed in future release.

Thank you.


#3

Thanks! Can you estimate, when this release will be? Will it take days, weeks, months? Because we can’t publish the Update of the App until it works again.


#4

Hello @dabiathlet,

It won’t take much time. We are planning to release it with the upcoming release within two weeks.

Thank you.


#5

Hi @dabiathlet,

This issue has been fixed. Please update rtMedia to its latest version 4.0.7

Thanks


#6

Hi Kiran! Tested it and it’s working! But now the parameter “description” is missing. Could you please add this again? Thanks! Mario


#7

Hello @dabiathlet,

We have discussed with the team and we are looking into your query. We will add the description parameter in next release.

Thank you for pointing out this to us.


#8