Media not displaying in rtMedia Pro v2.5.9


#1

I am using BuddyPress 2.1.1 and rtMedia 3.7.17 and I can upload media to the media location, however when I try to open it open it up in the viewer, I just get the No preview available message. I can get .jpgs to open, but not pdf, doc, etc.Is there something I am doing wrong or can try in order to fix this issue?


#2

Hi @silingi,

Are you testing on live server or on local site?

We are using google docs viewer which will use live URL to display documents, so local site will not be able to display it.


#3

I am testing via Instant Wordpress (locally). Does this make a difference?


#4

Hi @silingi,

Yes, you need to use live server for displaying documents with Google docs viewer as it works with live URL.

Thank you.


#5

Thank you for the response! Do you also know if there is a way to share the document/file with just one person rather than all friends, public, or private?


Share with single user
#6

Hi @silingi,

Sorry to say, but that is not possible.

Thank you.


#7

Okay, could you direct me to where the name “Media” is stored in the PHP files? I am wanting to change the name of it for a group project in class.


#8

Hi @silingi,

You can replace below text with your own in wp-config.php :

define ( 'RTMEDIA_MEDIA_SLUG', 'media' );
define ( 'RTMEDIA_MEDIA_LABEL', 'Media' ); 

For more information you can refer documentation -> http://docs.rtcamp.com/rtmedia/developer/rtmedia-defined-constants/.

Thank you.


#9

Thank you!

What about adding a link to the “media” location on one of my menus?


#10

@silingi – There is a way to share a file with only one user, however it’s a separate plugin. Lucky for us, it’s also free.

Dont worry that it has not been updated in 2 years, it hasnt had to be. It works just fine. Install it, configure the file extensions you want (and enter them like this pdf,zip,mp4,etc) – comma separated but no spaces.

Then when your members send a private message, they can attach a file to the private message, and as such, it’s only seen by the one member who receives the message.

Have fun

Ben


#11

Yes, but this is a file from the computer the user is on, not the files from the “media” storage.


#12

A file is a file, no matter where you upload it from. It doesnt matter if your uploading with the uploader, uploading to the media library, or using something other than WordPress, it will follow the php.ini configuration. If you cant have your own php.ini file, you’ll have to have your webhosting company configure a larger upload size for you. As long as the rtMedia setting for file uploads is correct, and it still wont work, it’s the PHP config file.


#13

Hi @silingi,

You already have created another thread relating to this issue.

@illusionsglass, Thank you.


#14