Media galery: Oops ! There's no media found for the request!


#1

There is nothing on the Media Site (Media Galery).

I put: (tried also different codes):

[rtmedia_media_uploader_attributes]

[rtmedia_gallery global=“true”]

but only see:

Oops !! There’s no media found for the request !!

Is it not possible when I use Buddypress to have a Page Media for All media?

When not logged in I see on this page upload button but it’s not allowed to upload and after Login the same: Oops ! There’s no media found for the request!

All Wp Buddypress bbpress rtmedia is newest.

Only by Buddy press seem groups to work.

In Groups there is a Media Tab but not in Main Stream (without choosing a group)


#2

Hello @JaroslawIstok,

[rtmedia_gallery global="true"]

The above shortcode will create a gallery with all uploaded media of any type (with Privacy = Public).

If you are not getting any media then please check if there are any media with privacy “Public”.

When not logged in I see on this page upload button but it’s not allowed to upload and after Login the same: Oops ! There’s no media found for the request!

Only logged in users will be allowed to upload the media.

In Groups there is a Media Tab but not in Main Stream (without choosing a group)

Could you please share any screenshot regarding this query?

Thanks.


#3

Media Button is to see on my Profile page from BuddyPress, also on Page Group:

There is no button on the stream Site of BuddyPress.

On the Site domain.com/media (Not in BuddyPress just normal wp Page with code [rtmedia_gallery global=“true”] is nothing to see (When logged in) besides "OOps…) All files are public… Only when logged out there is a picture of Upload and message thet only loggen in user can upload but after login it dessapears and I see again "Oops…)

Also, what I really don’t understand is:

When I have the page domain.com/media open (and see "Oops…) and than click the edit button on this site, than it’s not open the media site (with [rtmedia_gallery global=“true”] on it) in editor but everytime the last published blogpost. That is what I really can’t explain…


#4

With MediaPress it is working, Sitewide gallery which is seemlessly not possible with rtmedia ;o(


#5

Hello @JaroslawIstok,

Let’s discuss your issues one by one. I will assist you with each of them.

You have attached a screenshot of Media tab where it is showing the all the media properly.

There is no button on the stream Site of BuddyPress.

Could you please explain where you are expecting the button ( I am assuming the Media button which can redirect you to the screen you have attached. )? Any screenshot will be helpful to us to understand the query.

On the Site domain.com/media (Not in BuddyPress just normal wp Page with code [rtmedia_gallery global=“true”] is nothing to see (When logged in) besides "OOps…) All files are public… Only when logged out there is a picture of Upload and message thet only loggen in user can upload but after login it dessapears and I see again "Oops…)

If you have used this public media shortcode on any WordPress Page/Post and it is showing the photos to non-logged in users then those media will also be visible to logged-in users.

If you are talking about the rtMedia Uploader and you want to display the uploader then you will need to change the shortcode. Please, explain to me your exact requirement I will help you to develop the shortcode.

When I have the page domain.com/media open (and see "Oops…) and than click the edit button on this site, than it’s not open the media site (with [rtmedia_gallery global=“true”] on it) in editor but everytime the last published blogpost. That is what I really can’t explain…

I am not clear regarding your query. Please, let me know the step how I can regenerate this issue on my end so that I can help you accordingly. Also, attach some screenshot to show which edit button you are facing issue with. Have you added the Shortcode in WordPress Post/Page?

Note: To avoid any conflicts, please once try to regenerate these issues with any wordPress default theme and other plugins disabled ( except rtMedia and BuddyPress ).

I look forward to your reply.

Thank you.


#6

Its easy to understand without more sceenes.

The standard buddypress activities site for all is stream.html There is no media Tab. I just wonder about it. Only by personal profiles and and groups.

There is no possibility to make a sitewide gallery for users as I see. Not in standard buddypress sites, gathering together all users uploads.

also no with normal wp page (with code) where I expected to se them (Uploads of users).

Plugin mediapress does all this withou complications, as I expected. So I just wonder why buddypress cooperates with rtmedia not mediapress. Sorry for this crital but true conclusion :o(

I desided to use mediapress…


#7