Max file Size Limit : N/A


#1

Hello !

I´ve got two problems :

  1. I get the following error at my error-log

12.05.2014 20:28:09 nervtdoch.de [client 84.46.120.0] Premature end of script headers: admin-ajax.php, referer: https://www.nervtdoch.de/wp-admin/media-new.php
12.05.2014 20:28:23 nervtdoch.de [client 84.46.120.0] Premature end of script headers: admin-ajax.php, referer: https://www.nervtdoch.de/aktivitaet/

an the upload of files don´t work

  1. If the filesize increase 32MB I get this error :
    nervtdoch1.mp4(34.5 mb) Max file Size Limit : N/A 34.5 mb

rtMedia tells me, that the filesize would be not available…but I already made the following
modifications :

a.) PHP.ini

<? safe_mode = off session.save_path = "/tmp" file_uploads = On upload_max_filesize = 64M post_max_size = 70M max_input_vars = 3000 max_execution_time = 300000 max_input_time = 2400 memory_limit = 128M magic_quotes_gpc = On ?>

b.) I change the last line in wp-config.php with this :

define(‘WP_MEMORY_LIMIT’, ‘128M’);

So I think I have all done to manage uploads of bigger sized videos.
I don´t understand why wordpress tells me max file size limit not avaliable…
I know that the normal limit is 32 MB I think, but I thougth with my modification in the wp-config it should be increased.
Whatever… I get in addition to the error of premature end of scripts Header the error, that the max file size limit where not available if I try to upload a file with a filesize bigger than 32 MB.

Do you maybe have an Idea ?

thankyou !!!
Oliver

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/65263/2014/05/upload2.png


#2

Hello !

short update… I fixed the Premature end of script headers…
I have absolutely nothing done but my .htaccess has been corrupt.
I just uploaded the htaccess again and this fault has been gone…

But my problem of file size limit n/a is still there…

Thanks
Oliver


#3

Hi Oliver,
Can you give me debug info available under Support tab from rtMedia admin page?


#4

Hello Ritesh !

Shure… :slight_smile:

The supportinfos are :

Home URL https://www.nervtdoch.de
Site URL https://www.nervtdoch.de
PHP 5.5.11
MYSQL 5.5.31
WordPress 3.9.1
BuddyPress 2.0.1
rtMedia 3.6.14
OS SunOS
Imagick Not Installed
GD bundled (2.1.0 compatible)
[php.ini] post_max_size 80M
[php.ini] upload_max_filesize 64M
[php.ini] memory_limit 256M
Installed Plugins WP Easy Paypal Payment Accept by Tips and Tricks HQ version v3.8,
BackWPup by Inpsyde GmbH version 3.1.2,
BuddyPress Activity as Wire by Brajesh Singh ( BuddyDev ) version 1.0,
Bp Chat by Brajesh Singh version 1.1 trunk,
BP checkins by imath version 1.2.2,
BuddyMenu by Lee Hodson version 2.2.0,
BuddyPress Activity Plus by WPMU DEV version 1.6,
BuddyPress - Private Aktivitäten by Meg@Info version 1.3.1,
Buddypress Friend of a Friend (FOAF) by Florian Schiessl version 2.0,
BuddyPress login redirect by Jatinder Pal Singh version 2.1,
rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 3.6.14,
BuddyPress Message Attachment by E-Media Identity version 1.1,
Buddypress Social by Charl Kruger version 2.0,
Buddypress Xprofile Custom Fields Type by donmik version 1.5.8.7,
BuddyPress by Die BuddyPress-Community version 2.0.1,
Cookie Law Info by Richard Ashby version 1.2,
Dynamic Widgets by Qurl version 1.5.7,
Events Manager by Marcus Sykes version 5.5.3,
Facebook Friends Inviter by Lee Hodson version 1.0.5,
Nav Menu Images by Milan Dinić version 3.2,
Simple Ads Manager by minimus version 2.2.80,
Toolbar Remixed - Free by Jacob Schweitzer version 1.2.6,
Visual Form Builder by Matthew Muro version 2.8.1,
WooCommerce by WooThemes version 2.1.8,
wp-championship by tuxlog version 4.4,
WP-FB-AutoConnect by Justin Klein version 3.1.10
Theme Name BuddyBoss Child Theme
Theme Version 3.1.7
Author URL http://www.buddyboss.com
Template Overrides plugins/buddypress-media/templates/media/album-gallery-item.php,
plugins/buddypress-media/templates/media/album-gallery.php,
plugins/buddypress-media/templates/media/album-single-edit.php,
plugins/buddypress-media/templates/media/media-gallery-item.php,
plugins/buddypress-media/templates/media/media-gallery.php,
plugins/buddypress-media/templates/media/media-single-edit.php,
plugins/buddypress-media/templates/media/media-single.php,
plugins/buddypress-media/templates/media/uploader.php
Total Albums 1
Total Photos 27
Total Videos 10

Hope that helps… :slight_smile:
Bye
Oliver


#5

Hello Ritesh !

I talked to my webhoster…they told me that the maximum filesize would be 16 MB, but I think this has nothing to do with the n/a filezize in my website…or?
By the way I already uploeded files bigger than 16 MB up to 31,99 MB :slight_smile:

bye
Oliver


#6

Yes, it shouldn’t return N/A. It should show minimum value of “upload_max_filesize” and “post_max_size”.
Can you check it with other plugins disabled and with WordPress default theme?


#7

Having the same issue here and no resolution after changing/adding .htaccess and php.ini in the root directory and plugin directory


#8

Any resolution?


#9

Can you give me debug info? You can find it under rtMedia admin > Support tab.


#10

PHP 5.4.27
MYSQL 5.6.17
WordPress 3.9.2
BuddyPress 2.0.2
rtMedia 3.7.4
OS Linux
Imagick Not Installed
GD bundled (2.1.0 compatible)
[php.ini] post_max_size 350M
[php.ini] upload_max_filesize 350M
[php.ini] memory_limit 256M
Installed Plugins BP Group Hierarchy by David Dean version 1.4.3,
BuddyPress Group Live Chat by David Cartwright version 1.1,
BP Group Reviews by boonebgorges version 1.3.2,
Buddydrive by imath version 1.2.0,
BuddydriveS3 by dbezborodov version 1.1,
BuddyPress Activity Privacy by Meg@Info version 1.3.3,
BuddyPress Extended Friendship Request by Brajesh Singh version 1.0.4,
Buddypress Friend of a Friend (FOAF) by Florian Schiessl version 2.0,
BuddyPress Friends On-line (FOL) by WP-BP version 0.4.3.1,
BuddyPress Hovercards by Mike Martel version 1.1.3,
BuddyPress Links by Marshall Sorenson (MrMaz) version 0.9,
rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 3.7.4,
BuddyPress MyMood by Ayush version 1.7,
Buddypress Social by Charl Kruger version 2.0,
BuddyPress Wall by Meg@Info version 0.9.3,
Buddypress - Who clicked at my Profile? by Florian Schiessl version 1.8,
BuddyPress by The BuddyPress Community version 2.0.2,
BuddyPress Avatar Bubble by slaFFik version 2.5.1,
Easy Coming Soon by Deepesh paiwal version 1.3.1,
Facebook Members by Crunchify version 5.5.1,
Hidden WP Admin by FastLine Themes version 1.1,
Invite Anyone by Boone Gorges version 1.3.1,
jQuery Vertical Mega Menu by Lee Chestnutt version 1.3.3,
Login With Ajax by Marcus Sykes version 3.1.2,
MediaCore Activity Feed by Allan Haggett version 1.0,
MediaCore by Derek Harnanansingh derek@mediacore.com version 2.6,
Page Loading by Arefly version 1.0.5,
Quick Cache by s2Member® / WebSharks, Inc. version 140605.1,
RRF Scroll To Top by Rasel Ahmed version 1.1,
Wordfence Security by Wordfence version 5.1.9,
WordPress Importer by wordpressdotorg version 0.6.1,
WP Clone by WP Academy by WP Academy version 2.1.7,
WP Social Invitations by timersys version 1.5.5
Theme Name Explicit
Theme Version 1.3
Author URL http://www.industrialthemes.com
Template Overrides plugins/buddypress-media/templates/media/album-gallery-item.php,
plugins/buddypress-media/templates/media/album-gallery.php,
plugins/buddypress-media/templates/media/album-single-edit.php,
plugins/buddypress-media/templates/media/media-gallery-item.php,
plugins/buddypress-media/templates/media/media-gallery.php,
plugins/buddypress-media/templates/media/media-single-edit.php,
plugins/buddypress-media/templates/media/media-single.php,
plugins/buddypress-media/templates/media/uploader.php
Total Albums 2


#11

That’s strange, it should show minimum value of upload_max_filesize and post_max_size. You can check here -> https://github.com/rtCamp/rtMedia/blob/master/app/main/controllers/shortcodes/RTMediaGalleryShortcode.php#L66 from where this value is shown.

Can you check it with WordPress default theme and with other plugins disabled?


#12

Hi I am also having this N/A file limit issue, I have tried disabling all other plugins and am using the default 2014 theme. My debug info is:

Home URL http://sf012249.webs.sse.reading.ac.uk Site URL http://sf012249.webs.sse.reading.ac.uk PHP 5.4.18 MYSQL 5.5.36 WordPress 4.1 BuddyPress 2.1.1 rtMedia 3.7.31 OS Linux Imagick Not Installed GD bundled (2.1.0 compatible) [php.ini] post_max_size 64M [php.ini] upload_max_filesize 64M [php.ini] memory_limit 256M Installed Plugins BuddyPress Activity Privacy by Meg@Info version 1.3.3, BuddyPress Like by Darren Meehan version 0.2.0, rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 3.7.31, Buddypress Social by Charl Kruger version 2.0, BuddyPress by The BuddyPress Community version 2.1.1, Events Manager by Marcus Sykes version 5.5.5, Image Watermark by dFactory version 1.3.3, Regenerate Thumbnails by Viper007Bond version 2.2.4, Search Everything by Zemanta version 8.1.3 Theme Name Twenty Fourteen Child Theme Version 1.0.0 Author URL http://example.com Template Overrides plugins/buddypress-media/templates/media/album-gallery-item.php, plugins/buddypress-media/templates/media/album-gallery.php, plugins/buddypress-media/templates/media/album-single-edit.php, plugins/buddypress-media/templates/media/media-gallery-item.php, plugins/buddypress-media/templates/media/media-gallery.php, plugins/buddypress-media/templates/media/media-single-edit.php, plugins/buddypress-media/templates/media/media-single.php, plugins/buddypress-media/templates/media/uploader.php Total Albums 3 Total Musics 1 Total Photos 24

Any ideas?


#13

If you’re trying to upload files larger than 64MB, it will not allow it. You need to update your php.ini with a larger upload limit. 64M means 64 Megabytes. To bump it to 500MB enter the number 500M as an example.


#14

It will not even let me upload a file which is 32mb… I have managed to upload a one second clip! which was 1.6mb

My ini.php file is in my wp-admin folder, is this the correct location?

I have tried changing the file to read:

upload_max_filesize = 500M post_max_size = 500M max_execution_time = 1000

still no joy…


#15

The post max size does not need to be 500M, that’s nothing to do with uploads. And a max execution should be 300. Neither of those two settings are giving you problems with this, but you should adjust them anyhow.

https://www.YOURSITE.com/wp-admin/admin.php?page=wc-status

Go there and tell me what “WP Max Upload Size:” says please!


#16

I have managed to fix it! It seems that my php.ini file was not in the right place. It had to be in the public.html folder rather than the wp-admin folder!

Thanks for your help :slight_smile:


#17