Mail Stack Install


#1

I am trying to set up mail and ran the “stack install” command. At the end of the install I get an error “1045 access denied for user root @ localhost (using password yes). Unable to create ViMbAdmin database”.

I can access phpmyadmin and login no problem, have searched Google for an answer but no luck at all can anyone help with this please. Mail set up on my VPS is the last problem to solve!

Thanks guys.


#2

Hi, Are you able to login to database using following command only?

mysql

#3

Thank you so much for reply…no, I can not log in using command “mysql” . I followed a tutorial to reset the mysql password to gain access to phpmyadmin which now works.

In doing that I seem to have caused other problems, I get the error when trying to install mail and just discovered I get same 1045 error when trying to install another Wordpress site.


Whats wrong with my phpmyadmin
#4

Hi, EasyEngine use only mysql command to login to MySQL, You need to store MySQL password to following file:

vim ~/.my.cnf

and add your password to file

[client]
user=root
password=password

and after that you need to check mysql command is working or not


#5

Hi, Making progress with this.

Can now log in using “mysql” command but when trying to install mail stack I get new error: “Unable to set up ViMbAdmin default database , exit status = 1” Thanks a lot for your help, its very much appreciated.


#6

UPDATE: When trying to log into ViMbAdmin with a browser I get this error:

“/var/www/22222/htdocs/vimbadmin/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php LINE 102 An exception occured in driver: Connection refused”

When browsing files with Filezilla I see:

/DBAL/ exists but the other files are missing(Driver/AbstractMySQLDriver.php).


#7

HI, Its beacuse of previous ViMbAdmin incomplete setup.

Just do following steps.

ee stack purge mail
ee stack install mail

#8

I have tried doing that twice but still get same error, everything else works perfectly, just stuck with mail install!


#9

Hey Jim,

Check the config files for website name or host name

here /etc/nginx/sites-available/

Just find the name you are giving either ip or website url remove it or rename it.

mv oldname newname

then go to databases folder /var/lib/install remove the db name here.

The better way is to find the folders and remove mail install folder

open ee.conf set db name true, username true and table prefix so that you can give custom names for db and table prefix it will not override the old one and it will created new one.

Still face any issue give me the screen shot of the error.

Best Sreenivas


#10

Thanks for reply, I edited the ee.conf file as you described and still get the same error, I admit to being lost with this and not sure how to proceed. When I run mail stack install I can see a database is created with phpmyadmin but it is empty. When I go to folder /var/lib/ there is no “install” folder.


#11

I am sorry for al the confusions,

Just go through the below article and make sure that you have configured it well.

If are facing issues.

My suggestion is that you can rebuild your OS and reinstall the EasyEngine again.

Thanks


#12

Took a look at the link but that is way to complicated for a begginer like me, I think I will set up email off my server using godaddy. I am on my fourth install already time to give up!

I appreciate you trying to help.

Thank you.


#13

Hi @jims45

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#14