Low RAM usage, high CPU usage


#1

Hi,

I have a high-traffic site running on Easyengine. It’s constantly using the maximum of 10 CPU cores on the VPS, but only around 5GB of RAM. I’ve set the php memory limit to be much higher than this.

Is there a way to get it to use more RAM? Hopefully with the effect of decreasing the load on the CPU’s.

Any help would be much appreciated.


#2

Hello Redstar, you will probably have to improve the MySQL configuration. At first try to see what application is using so much CPU, you can install htop apt install htop and launch it with htop to see all services running. Then if it’s MySQL you can follow this tutorial to adjust cache and buffers : https://easyengine.io/tutorials/mysql/query-cache/ https://easyengine.io/tutorials/mysql/mysqltuner/


#3

Hi in my case php fpm consume alot of ram what can i do


#4

Hello, you can decrease the maximum memory in your php.ini configuration but most of time, that mean there is a memory leak somewhere, due to error in your website code or a bug in php-fpm


#5

Well my site total request goes around 22k How can i find the leak although its a fresh install so i dont think there is a leak throug plugin 50 user For 5 min


#6

Just enable wordpress debug_log and check nginx error_log to see if there are some issues.


#7

Hi brother one question does in need redis + fastcgi cache or only one of them will do the work?


#8

Only one of them should do the job. With a good server and easyengine, wordpress should load fast even without cache. If it’s not the case, the issue isn’t related to easyengine configuration.


#9