Link is wrong for rtMedia uploaded image link in comments with WPMU network env


#1

Hi,

My wordpress deployment is multi site network subdomain setup, buddypress is installed in one subdomain currently with the new theme InspireBook, and the primary site and other subdomain sites use other themes.

Whatever I activated the rtMedia Pro in netowrk level or individually, when I upload images in buddyPress site blog posts or other subdomain blogs, the generated link is always links to the media tab of the user buddypress profile page.

If I upload image to a buddypress blog post, the image will show in the profile page and can be edited. But if I clicked the Media tab, that image can not be found.

If I upload image to other subdomain blog post, the link points to the user profile page too (buddypress site), but one error message saids “Sorry !! There’s no media found for the request !!”

Both situations ,the file is successfully uploaded.

The generated comments in buddypress site blog post:

  BYN_6575.JPG  

BYN_6575.JPG

the link: http://community.fitnesshubs.com/2014/03/13/use-social-article-to-post/

The generated comments in other subdomain blog post:

  DSC_4302.JPG  

DSC_4302.JPG

the link: http://running.fitnesshubs.com/2014/02/26/maffetone-method/

The uploaded images work well in activity updates and forum, would it be also that when I click the images in the comments, the gallery box should be opened to view the images?

Could you take a look at it?

thanks!


#2

Could you help check this?

Thanks!


#3

@hanzhidou, Sorry for the late reply. I visited both of your sites and looks like both are down. It shows the error message "The requested URL could not be retrieved".


#4

this was a private reply with post_id 62329


#5

You have activated BuddyPress in one the subdomain blog, so it is not network activated right?

If I upload image to a buddypress blog post, the image will show in the profile page and can be edited. But if I clicked the Media tab, that image can not be found.e found.

In media tab you can only see media that were uploaded through media tab or through activity update. Even BuddyPress group media won’t be shown in media tab. Please check this blog post -> https://rtcamp.com/rtmedia-3-4-simplified-group-privacy/ The media’s attached to blog post comment will not be shown in Media tab and that’s why showing no media found message.

Please check and confirm whether BuddyPress is network activated or not.

I tried domain mapping but still it shows “The requested URL could not be retrieved”.


#6

BuddyPress and all rtMedia plugins are network activated.

My Buddpress configuration as blow:

define ( 'BP_ROOT_BLOG', 4 );

I use one subdomain (community.fitnesshubs.com) as the Buddypress root, the primary domain is just one blog to collect all blogs from subdomains.

define ( 'BP_ENABLE_ROOT_PROFILES', true ); Put profiles in the root — http://community.fitnesshubs.com/username/

define( 'BP_ENABLE_MULTIBLOG', true );

BP_ENABLE_MULTIBLOG is a BuddyPress constant that, when defined as true, allows your BuddyPress content to be displayed on any site in your WordPress Multisite network. By default, BP_ENABLE_MULTIBLOG is disabled.

I tried giving comments with one photo in the primary site post again:

The image link in the post is: http://fitnesshubs.com/wp-content/uploads/rtMedia/comments/2245/2014/03/sohp_flower-150x150.jpg

when I clicked it, it jumped to http://community.fitnesshubs.com/hanzhidouwb/media/50/ and I got "Sorry !! There's no media found for the request !!" in the page.

Then I changed the url to http://fitnesshubs.com/author/hanzhidouwb/media/50/

One page with the photo showed up!

If from another sub site, it works also if I changed the url to like below http://running.fitnesshubs.com/author/hanzhidou/media/34/

Looks if we use current domain instead of always using buddypress root domain, and if not in buddypress root domain, use the current domain's 'author' link, the problem can be solved.

Attachment Link(s):

https://rtcamp.com/wp-content/uploads/rtMedia/topics/62373/2014/03/rtMedia-Comments-Photo_Test.png


#7

@hanzhidou, got the issue, thanks for pointing out. This issue will be fixed and will be updated in future release. We had created the issue, you can track status here -> http://git.rtcamp.com/rtmedia/rtmedia-pro/issues/72


#8

two months passed, this issue is not assigned yet, could you help prioritise it?

Thanks!


#9

@hanzhidou,
apologies for delay in this. There are some prior works which needs to be done first. Don’t worry this has been reported to our issue tracking system so it will be resolved.


#10