Lightbox is not working


#1

Lightbox is not working on my site, even though I have the lightbox option selected in ‘settings’. I’m not sure what the issue could be, it was working before I did a recent plugin update for rtmedia. When image is clicked on, it just goes to a page with the image instead of opening lightbox. This is not good for me because I have a dating site and it just doesn’t work well without lightbox.

I have no idea why lightbox stopped working, does anyone have any suggestions on how to get it working again?


#2

Hi Garrett,

Lightboxes are working as expected on my test website. I am currently using rtMedia version 4.1.6.

Is it possible for you to disable other plugins, and check if this problem persists?

Regards, Joel Abreo


#3

Hi,

I have the same problem as garrett800, but I’m not sure how long the lightbox has not been working as I had it off for a while. I have deactivated all my plugins and also my child theme, but no change. I am currently using rtMedia version 4.1.6. Any idea what to do?

Regards

Petra


#4

Please share the debug info of your website along with website URL that will help us to identify the mentioned issue.

Debug info can be found under rtMedia -> Settings -> Support tab.

Thanks,


#5

Hi, thanks a lot for quick reply. My site is still under maintenance mode as it’s still not finished yet, but I have deactivate it for you so you have access to it. Once you finish with it, please let me know so I can put it back to maintenance mode again. Here are my DEBUG INFO:

Home URL http://hotloverspassion.com Site URL http://hotloverspassion.com PHP 5.5.38 MYSQL 5.6.23 WordPress 4.6.1 BuddyPress 2.6.2 rtMedia 4.1.6 OS Linux Imagick Not Installed GD bundled (2.1.0 compatible) [php.ini] post_max_size 128M [php.ini] upload_max_filesize 128M [php.ini] memory_limit 768M Installed Plugins Content Aware Sidebars by Joachim Jensen version 3.3.3, bbPress by The bbPress Community version 2.5.10, iThemes Security by iThemes version 5.6.2, BP Force Profile Photo by Brajesh Singh version 1.0.4, BP Profile Message UX Free by shanebp version 1.5, BP Redirect to Profile for Buddypress by Brajesh Singh version 1.2.1, Buddy Progress Bar by danbp version 1.0.2, rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 4.1.6, BuddyPress Xprofile Custom Fields Type by donmik version 2.5, BuddyPress by The BuddyPress Community version 2.6.2, Conditional Profile Fields for BuddyPress by Brajesh Singh, Anu Sharma version 1.1.9, Contact Form 7 by Takayuki Miyoshi version 4.5.1, GEO my WP by Eyal Fitoussi version 2.6.6.1, GMW Add-on - Xprofile Fields by Eyal Fitoussi version 1.4, Loco Translate by Tim Whitlock version 2.0.7, Loginizer by Raj Kothari version 1.2.0, The Post Grid by RadiusTheme version 1.2, WangGuard by WangGuard version 1.7.2, Wise Chat by Marcin Ławrowski version 2.4.1, WP Maintenance Mode by Designmodo version 2.0.8, WP-SpamShield by Scott Allen version 1.9.9.2 Theme Name Sweetdate Child Theme Version Author URL http://seventhqueen.com Template Overrides plugins/buddypress-media/templates/media//album-gallery-item.php, plugins/buddypress-media/templates/media//album-gallery.php, plugins/buddypress-media/templates/media//album-single-edit.php, plugins/buddypress-media/templates/media//media-gallery-item.php, plugins/buddypress-media/templates/media//media-gallery.php, plugins/buddypress-media/templates/media//media-single-edit.php, plugins/buddypress-media/templates/media//media-single.php, plugins/buddypress-media/templates/media//uploader.php Total Albums 1 Total Photos 2

Thanks

Petra


#6

It looks like we are using the same theme, Sweetdate child. I’m guessing there’s an issue with the new version of RT Media and the theme.


#7

It seems like a problem coming from SweetDate child theme only.

Check their demo site http://seventhqueen.com/demo/sweetdatewp/members/demo/#my-photos all the photos open on the single page.

var rtmedia_lightbox_enabled = "1"; this value set by rtMedia setting which is correct.

Kindly check with the sweetdate developer team, I hope you will get a quick solution on it.


#8

I agree, but it’s probably the Sweetdate parent theme, because that’s where almost all of the code is. I have placed a support ticket with Seventhqueen about the issue and let them know it’s also happening on their demo site.


#9

Yeah. It’s from the parent theme. If you get any solution from them, please let us know here. So that it will useful for others.


#10

Thanks guys. Hopefully they will find a solution for this soon :slight_smile:


#11

RTMedia has put out 2 updates since we started this thread, but these updates have not fixed the issue. I will wait for Seventhqueen to respond. Since their own demo site is having the same issue, hopefully they can find a solution and update their theme. It’s been a long time since they put out a theme update, I think at least a few months.


#12

@garrett800

Yes, we released rtMedia new updates but those are not related to lightbox issue which you mentioned. That issue is causing because of SweetDate theme.


#13

Does anyone know if Seventhqueen resolve and if so what the issue was this as I see it is now working on their demo site.

It was working fine on mine and I havent updated the theme in quite a while but have updated rtMedia so not sure if it is just the theme. Is there a way to get an old version of rtMEdia to test?


#14

@jonathanb

Please check your website once with the WordPress default theme. I hope it will work fine with that.

You can always download the older version of rtMedia plugin from here https://wordpress.org/plugins/buddypress-media/developers/

Thanks,


#15

Thanks Nitun I will install an older version.

I just restored an old version into a test area and updated all the plugins apart from rtMEdia so the theme and everything else was exactly the same except the restored site was running rtMedia 4.0.1 and it worked fine. As soon as I updated rtMedia to the latest version the lightbox stopped working so there must be some conflict with the latest rtMedia and something else running.


#16

I went back to version 4.1.5 and it works fine with the same version theme so must be something from 4.1.6 that conflicts with the sweetdate theme.


#17

Its seems like Sweetdate theme has not updated there template structure as per rtMedia recent release. if anyone can provide Sweetdate theme so i can cross check it at my end.


#18

Sweetdate did release an update of their theme (2.9.6), and it fixed the issue for me. Lightbox is working again.


#19

@garrett800 Good to know that. Is it working for rtMedia latest release 4.1.6 ?


#20

@naveengiri Lightbox is working for me with the latest release of rtMedia 4.1.8 and the latest release of SweetDate theme 2.9.6