Letsencrypt not installing SSL


#1

Hi all,

I have a droplet on Digitalocean, and there are two wordpress blogs installed on it. I had added a letsencrypt SSL certificate before adding the second wordpress blog.

So, that first domain, didn’t give me any problems. However, now that I installed the second blog I cannot add SSL through letsencrypt for that new domain name …

The error it gives me :

Unable to setup, Let’s Encrypt Please make sure that your site is pointed to same server on which you are running Let’s Encrypt Client to allow it to verify the site automatically.

Now I am wondering : is it only possible to have 1 SSL certificate because both domains are under 1 IP adress (1 droplet) … could this be the issue ?

Lex

Ps… I have CF DNS set to FULL (strict), so that’s not the issue.


#2

Hello, You can issue more than a single certificate on the same IP, but you should not enable cloudflare Full strict mode if you do not use their origin certificates, and you may have to disable cloudflare proxy to issue another cert because letsencrypt only see cloudflare servers IP instead of your droplet IP


#3

Hi … Thanks for replying …

Actually I’ve tried it without CF as well … even with the DO dns nameservers … Letsencrypt gave me the same error .

The only thing I can think off that is different this time around is that the domain name is registered at Godaddy, instead of my regular registrar … and besides that it’s a .NL name …

But this shouldn’t be the issue … or am I missing something here ?


#4

I am having a similar problem after moving from domain from one droplet to another…very eager to find a solution to this problem as it is still redirecting to https which gives an error while http directly input will work. Very frustrating!


#5

I solved it by taking away the IP6 records in the DNS … After that I also moved the domain to a newly created droplet. After creating the new droplet I entered the new IP adres (of the new droplet) in the DNS as usual … it worked for me without issues …

The only problem I ran into was letsencrypt trying to use IPv6… once that was out of the way, I had no issues …

What is it exactly you are trying to accomplish ? Move the domain to another droplet including the SSL ?