Letsencrypt issue


#1

Hello there,

I am trying to use letsencrypt with one of my websites. I actually tried on two of them. I get the message:

Unable to setup, Let’s Encrypt Please make sure that your site is pointed to same server on which you are running Let’s Encrypt Client to allow it to verify the site automatically.

The domain was pointed to another VM - another ip, and letsencrypt worked fine there. However, i also tried with a new domain, the problem persists.

I am using Easyengine configured with wpredis, php7 on Ubuntu 16.04.

Any thoughts? I tried anything i’ve found in the community.

Thanks in advance.


#2

Hi there,

You mentioned that the domain was pointed to another VM in the past; was this also running EasyEngine + Let’s Encrypt? If so, you need to uninstall Let’s Encrypt first on that VM before attempting to reinstall it on the current VM.

Also, ensure that your @ and www DNS records are both apex (A Record) and not common name (CNAME Record). Is this also the case?

Hope it helps, let us know if you make any progress.


#3

Hey,

Yes, the previous machine had letsencrypt with EE. Do i simply turn it off? How should i uninstall / remove Letsencrypt on that VM? Both records are A.

Thanks in advance


#4

Ah, the command is ee site update example.com --letsencrypt=off

Note that you need to point your DNS to the old server first, make sure it propagates, then run the above.

After which you then change the DNS to point to the new server, make sure the DNS propagates, and install Let’s Encrypt there (with the ee site update example.com --letsencrypt command).

Source: https://easyengine.io/tutorials/nginx/letsencrypt/


#5

Thanks, I’ll try it.


#6

I have the same issue, but in my case the previous VM no longer exist. what can i do? i have this domain (instanfot.com) but it shows that the ssl is expired and i cant modify because the VM no longer exist


#7