LetsEncrypt is working but site info says SSL disabled and can't renew


#1

The SSL on my site is working fine with LetsEncrypt managed by EasyEngine. I went in to renew manually today and I get the following:

$ sudo ee site update themeofthecrop.com --letsencrypt=renew
Cannot RENEW ! SSL is not configured for given site .

Looking at the site info, it says that SSL is disabled:

$ sudo ee site info themeofthecrop.com
Information about themeofthecrop.com:

Nginx configuration	 wp basic (enabled) 
PHP Version		 5.6
HHVM			 disabled
SSL			 disabled

However, when I inspect the SSL cert on my site, it is running with LetsEncrypt, and I have always only ever used EasyEngine to manage this site.

During the last manual renewal that I did had some issues, and it looks like the cert was renewed successfully but the site settings still said SSL was “disabled”.

Is there a safe way I can enable SSL in the site settings and renew the certificate? Is it safe to run ee site update themeofthecrop.com --letsencrypt?


#2

It is safe to ww site update domain.com --le.


#3

Thanks @portofacil, I ran it and everything went smoothly!


#4

@portofacil I have a peculiar problem. And unable to find a direct solution. I renewed LetsEncrypt SSL earlier this month 09-May. Successfully. The original certificate was meant to expire on 20-May. Post successful renewal, expiry was set for 7-Aug.

Today, browsers are calling out my site as unsafe, as the certificate has expired.

I tried to run the renew certificate command (the EE way) and console response was “renewal not possible as certificate validity is greater than 30 days”.

I am a not a coder or sysadm, just a newbie to WP… kindly advise… thanks in advance.


#5

@vyname that sounds similar to a problem I faced a while back: Can't re-enable LetsEncrypt. Nginx fails to reload


#6

Have you tried a reboot?

Reboots usually behave magically because they force the server to clean all kind of caches while correctly restarting all services.

I’d try a reboot, then see how the issue evolves.


#7

Thanks @NateWr will try all that you did… hopefully, i will chance upon the fix. :slight_smile:


#8

Yes I did try the reboot option earlier; did not fix the problem.


#9