Let's encrypt not working


#1

I try to create an SSL for my site with this command.

ee site update mydomain.com --letsencrypt

Then after pressing y this shows up and nothing happens. After 1h i canceld it and tried it again but nothing changed.

Please Wait while we fetch SSL Certificate for your site.
It may take time depending upon network.

Any ideas?

thanks


#2

@sydl Can you please share, version of EasyEngine and Operating System that you are using?


#3

Hi,

i use Ubuntu 16.04 and the latest version of ee (downloaded & install yesterday)


#4

Suggestion: Maybe it’s DNS-related? I experiencing something like it yesterday on a digitalocean VPS, where I’m moving a domain. I’m setting up the sites via EE and testing by putting the IP and domain in my hosts file, but when adding Let’s Encrypt certs to the sites, the DNS for the domain needs to point properly to the server.


#5

Had the problem again a while ago, even if I had an A record (without www) pointing to the right IP.

One of these things solved it:

  1. I added a CNAME record pointing the www.-version of the domain to the domain without www.

  2. I allowed traffic on port 443 (https) in the firewall


#6