Lets encrypt certificate not auto renewing


#1

Hey guys im using ee v3.7.4 and i set up my website to use letsencrypt ssl. I have however run into a problem where the certificate is not being renewed by the automatic cron job set by ee.

When i run the renew command

ee site update example.com --letsencrypt=renew

i get the following response:

Renewing SSl cert for https://example.com Reload : nginx [OK] SUCCESS: Certificate was successfully renewed For https://example.com Your cert already EXPIRED !. PLEASE renew soon .

the certificate expired yesterday 23/1/2017 and its still not renewing it what could be the problem


#2

I don’t know what the problem is, but the workaround is the following:

ee site update domain.com --le=off
rm /var/www/domain.com/conf/nginx/ssl*
cd /etc/letsencrypt
find . -name 'domain.com*' | xargs rm -rfv
ee site update domain.com --le

You first disable SSL for the site, remove all configuration files regarding such domain, then recreate the SSL site from scratch.

Try the commands above in a test environment first: they work for me, but you know I can’t take any responsibility over your server.

[EDIT] It might be necessary to clear all chaches in order to publish the new cert: ee clean --all.


Problem with Let's encrypt
#3