LaTeX images on index.php


#1

Hi everyone,

I just switched to your great theme and encountered a problem: I use the easy-latex plug-in to display formulas and stuff in my articles. The plug-in generates images of the formulas. These images show up correctly when displaying an individual article. However, with rtPanel 2.0.8, the images do not show up on the startpage where the current artciles are listet (index.php). In some other themes, e.g. Twenty Eleven 1.3, the images of the formulas are correctly shown on the startpage. Thus I suppose that the problem is caused by the theme/plug-in interplay which needs to be adjusted in some way.

The link to my (upcoming) blog is: http://www.quantonomic.com

I invested some time and learned that the index.php may handle images differently compared to other pages. Unfortunately, I don’t know anything about PHP (but just registered for a course, so I promise improvement) and thus could not solve the problem on my own.

I really appreciate any help. Thanks a lot. :slight_smile:


#2

Hi Quant,

For your formula images to display properly you would have to go to the Dashboard - > rtPanel -> Post & Comments section and under ‘Post Summary Settings’ uncheck ‘Enable Summary’ Option.

At present your blog shows excerpt on the front page. WordPress by default strips all html tags from the content when displaying excerpts. You will have to show the whole content for your formulas to display.


#3

Thanks a lot for the answer. It solved the problem! Great work, thanks again.


#4

Hi Quant,

Happy to know that your problem got solved.

Cheers!


#5