Last thumbnail image in Album or other view fails to load in lightbox


#1

When clicking on the last thumbnail or scrolling through images in the lightbox, the last image fails always to load and just shows the text ‘loading media’.

I get the following javascript error: ‘event.returnValue is deprecated. Please use the standard event.preventDefault() instead.’

I have a testsite here where you can view the error:(http://www.utopiamultimedia.com/testsite/members/mattaitch/media/).

I have tried disabling all plugins and changing the theme to Twenty Thirteen, but no joy.


#2

@mattaitch, Yeah, it is continuously making ajax request for last media. I just checked it on our demo site -> http://demo.rtcamp.com/rtmedia/ and is working perfectly fine. Can you reproduce the same on demo? Also give debug info from rtMedia admin -> Support -> Debug info


#3

this was a private reply with post_id 58725


#4

@mattaitch, are you sure it works perfectly fine with other plugins disabled and with default WordPress theme? Because markup for media listing getting change in your theme.

If you check "li" tag markup of media listing in your theme and at our demo site, you will notice, in your theme markup is something like li > div > a > img whereas it should be li > a > div > img for media lisitng.


#5

Hi Ritesh. This issue has now been fixed. Here are the details:

I remembered I installed a previous version of RTMedia first as it had the importer included for BP-Album. After importing the images from BP-Album I then updated the RTMedia plugin to 3.6.7 - this caused the issue. There was an update to RTmedia issued this evening, and I updated my current installation to 3.6.8 (I was going to reinstall the plugin to see if that fixed it).

I wonder if there was an issue with updating from 2.8 to 3.6.7... either way, it's fixed and working well. Thank you for your support.


#6

@mattaitch, that's strange. There shouldn't be any problem by updating from 2.8 to 3.6.7. Anyways, glad to see that your issue has been fixed :)


#7