Jetpack and Letsencrypt


#1

I updated one of my domains to using letsencrypt using ee update and now I’m having issues with Jetpack.

Jetpack debug info shows:

We were unable to make an XML-RPC request to your website. Please make sure that XML-RPC is turned on and that Jetpack is installed, activated and connected with your WordPress.com account. If the error persists, try disconnecting and connecting Jetpack again."}
[response] => Array

I’ve tried adding:

/** Admin over SSL */
define('FORCE_SSL_ADMIN', true);
/** Set Port to 443 */
$_SERVER['SERVER_PORT'] = 443;

to my wp-config.php with no luck.

Anyone managed to get Jetpack working properly when using LetsEncrypt?


"WordPress Address (URL)" & "Site Address (URL)" in WP Multi-site
#2

hey @thatchris

have you tried clearing your cache? I had a similar issue with after enabling the SSL’s too…

do

ee clean --all 

and let see if that fixes it…


#3

Thanks for the suggestion. I tried ee clean --all but I’m still getting the same error.


#4

fail2ban, ufw…

what about your logs?

i’m using jetpack and LE just fine…


#5

I was allowing http, https and ssh with ufw. Just to check I disabled ufw and fail2ban, ran ee clean --all again and I’m still getting the issue where Jetpack can’t access my xml-rpc.php

Other Jetpack services like Photon, Protect, publicize, etc. are working just fine. I’m just unable to use things like the iOS WordPress app to view, edit or create posts because it can’t reach my xml-rpc.php if I go through just WordPress.com.

If I manually add my site in the iOS app without connecting to WordPress.com it can find my xml-rpc.php just fine.


#6

ok so i guess we have a temporary fix…

strange really, i’m trying to sherlock holmes the issue but i cant get my head around it.

when you type in the url manually it works, so obviously something on the redirect side might be causing an issue…

when you type it manually, do you type it with the https:// or just the .com/xml-rpc.php?


#7

When I add my site manually to the iOS app I just do http.


#8

if i were in your position, i’d do a tail -f on the logs to see what the system is saying, and compare what happens between the manually and automatic way

tail -f /var/www/example.com/logs/* /var/logs/*.log

or something like that…

it would at least give us some insight into what is going on


#9

I’m usually in this community support area quite a bit, but for some reason, I’m just now seeing this issue, 5 months after the fact. While I don’t want to revive an old thread, I believe I have some input, to help resolve this issue.

I’ve been in contact with Jetpack about a different issue, but a similar error in their debug info. I’m actually getting ready to post a new support issue, in the EE community about it. I believe the issue you are having within the Jetpack debug info is related to how your “WordPress Address (URL)” and “Site Address (URL)” are defined in the General Settings - at least that was my issue.

In order for many of Jetpack’s features to work correctly, with an EE/Let’s Encrypt installation, both of these addresses must start with “https://”

In support of my suggestion above, I’ve provided an email response from Lisa (one of Jetpack’s happiness engineers), about my “similar issue”, as it relates to XML-RPC requests:

Can you confirm these settings, in your WordPress’ General Settings?


#10

There is quite a conversation at: "WordPress Address (URL)" & "Site Address (URL)" in WP Multi-site regarding the settings Jetpack requires, to work correctly (WordPress Address & Site Address)


#11