Issues with flie permissions


#1

After reisntalling wordpress with easy einge i have issue with updating wordpress plugins and themes it seems that problem lies with incorrect file permissons i tried to change it (from 755 to 777) still not able to update my theme using evento API and also ee info show : “MySQL User: root” and not "“MySQL User: mysql” as mention here https://rtcamp.com/easyengine/docs/commands/info/No idea if mysql running by root user causing this file permission issue ?
Please help
Rahul


#2

How you re-install wordpress with EasyEngine?

EasyEngine used following permission for websites
Note: replace example.com with your domain name.

  
chown -R www-data:www-data /var/www/example.com  
find /var/www/example.com -type d -exec chmod 755 {} \;  
find /var/www/example.com -type f -exec chmod 644 {} \;  

#3

Please give us following command output:

  
ls -la /var/www/example.com/htdocs  
ee info  
ee info example.com  

#4

Thanks for quick response:

Here are the detail you have asked for:

ls -la /var/www/mysite.com/htdocs:

drwxr-xr-x 5 www-data www-data 4096 Jul 14 17:50 .
drwxr-xr-x 4 www-data www-data 4096 Jul 14 15:13 …
-rw-r–r-- 1 www-data www-data 418 Jul 14 15:13 index.php
-rw-r–r-- 1 www-data www-data 19930 Jul 14 15:13 license.txt
-rw-r–r-- 1 www-data www-data 7194 Jul 14 15:13 readme.html
-rw-r–r-- 1 www-data www-data 4896 Jul 14 15:13 wp-activate.php
drwxr-xr-x 10 www-data www-data 4096 Jul 14 15:41 wp-admin
-rw-r–r-- 1 www-data www-data 271 Jul 14 15:13 wp-blog-header.php
-rw-r–r-- 1 www-data www-data 4818 Jul 14 15:13 wp-comments-post.php
-rw-r–r-- 1 www-data www-data 3087 Jul 14 15:13 wp-config-sample.php
drwxrwxr-x 14 www-data www-data 4096 Jul 15 08:50 wp-content
-rw-r–r-- 1 www-data www-data 2932 Jul 14 15:13 wp-cron.php
drwxr-xr-x 12 www-data www-data 4096 Jul 14 15:13 wp-includes
-rw-r–r-- 1 www-data www-data 2380 Jul 14 15:13 wp-links-opml.php
-rw-r–r-- 1 www-data www-data 2359 Jul 14 15:13 wp-load.php
-rw-r–r-- 1 www-data www-data 32671 Jul 14 15:13 wp-login.php
-rw-r–r-- 1 www-data www-data 8235 Jul 14 15:13 wp-mail.php
-rw-r–r-- 1 www-data www-data 11070 Jul 14 15:13 wp-settings.php
-rw-r–r-- 1 www-data www-data 25665 Jul 14 15:13 wp-signup.php
-rw-r–r-- 1 www-data www-data 4026 Jul 14 15:13 wp-trackback.php
-rw-r–r-- 1 www-data www-data 3032 Jul 14 15:13 xmlrpc.php


ee info:

NGINX (1.6.0):
user www-data
worker_processes auto
worker_connections 4096
keepalive_timeout 30
fastcgi_read_timeout 300
client_max_body_size 100m
allow 127.0.0.1

PHP (5.5.14-2):
user www-data
expose_php Off
memory_limit 128M
post_max_size 100M
upload_max_filesize 100M
max_execution_time 300

Information about www.conf
ping.path /ping
pm.status_path /status
process_manager ondemand
pm.max_requests 500
pm.max_children 100
pm.start_servers 20
pm.min_spare_servers 10
pm.max_spare_servers 30
request_terminate_timeout 300
xdebug.profiler_enable_trigger off
listen 127.0.0.1:9000

Information about debug.conf
ping.path /ping
pm.status_path /status
process_manager ondemand
pm.max_requests 500
pm.max_children 100
pm.start_servers 20
pm.min_spare_servers 10
pm.max_spare_servers 30
request_terminate_timeout 300
xdebug.profiler_enable_trigger on
listen 127.0.0.1:9001

MySQL (5.5.37):
user root
port 3306
wait_timeout 30
interactive_timeout 60
max_used_connections 4/151
datadir /var/lib/mysql/
socket /var/run/mysqld/mysqld.sock


ee info mysite.com

NGINX (1.6.0):
user www-data
worker_processes auto
worker_connections 4096
keepalive_timeout 30
fastcgi_read_timeout 300
client_max_body_size 100m
allow 127.0.0.1

PHP (5.5.14-2):
user www-data
expose_php Off
memory_limit 128M
post_max_size 100M
upload_max_filesize 100M
max_execution_time 300

Information about www.conf
ping.path /ping
pm.status_path /status
process_manager ondemand
pm.max_requests 500
pm.max_children 100
pm.start_servers 20
pm.min_spare_servers 10
pm.max_spare_servers 30
request_terminate_timeout 300
xdebug.profiler_enable_trigger off
listen 127.0.0.1:9000

Information about debug.conf
ping.path /ping
pm.status_path /status
process_manager ondemand
pm.max_requests 500
pm.max_children 100
pm.start_servers 20
pm.min_spare_servers 10
pm.max_spare_servers 30
request_terminate_timeout 300
xdebug.profiler_enable_trigger on
listen 127.0.0.1:9001

MySQL (5.5.37):
user root
port 3306
wait_timeout 30
interactive_timeout 60
max_used_connections 4/151
datadir /var/lib/mysql/
socket /var/run/mysqld/mysqld.sock


thanks


#5

Hello

The permission seems ok.
Please cross check now your plugin theme install/update properly.

Its still not works then its good you can provide us server access and wp-admin access to debug the issue.


#6

I will get back to you soon with more detail
Thanks for your help
Rahul


#7

Hello,
issue solved by reuploading msql dump its working fine now

thanks for your help
Rahul


#8