Issues redirecting Blogger home page, archive pages


#1

Completed the Blogger-to-WordPress migration process and posts are redirecting correctly, though it takes 5-10 seconds for the redirection process to complete.

Two issues:

  • how can the Blogger home page (e.g., example.blogspot.com) be redirected to the new WordPress blog page (e.g., example.com/blog) instead of the WordPress site home page (e.g., example.com)?

  • despite adding the code from your instructions to the WordPress .htaccess file, Blogger archive pages are redirecting to the WordPress home page, not their corresponding WordPress archive page. Note: WordPress is installed in a subdirectory (i.e., public_html/wp).

Any ideas?

Thanks!


#2

Hello exelexys,

  1. please check the <meta content='0; , the value is 0 then its a default behavior. We can’t do anything with it.
  2. You need to change the Javascript code and replace the custom domain URL with custom.com/blog/
  3. Please change the .htaccess rule as per the subdirectory installation. The .htaccess rules provided in our article is for root WordPress installation.

#3

Thanks for your response.

  1. Snippet of generated code below references meta content:
  
	  
	  
  
	  
	  
  
  1. Can you show me the exact JavaScript code change(s) to be made? Have tried a couple of things and it isn’t working.

  2. Tried placing the redirect rules in .htaccess file in /public_html and alternatively in the directory where WordPress is installed (/public_html/wp). Neither redirected the old archive pages to the corresponding archive pages on the new blog, but to the WordPress site home page. Any ideas?

Thanks!


#4

@exelexys,

#1. Is correct, we can’t do anything with that. The redirection will take that much time.
#2. Please use this code and replace it in blogger template, make sure to change the domain name, directory name (wp) and blog page.

<?xml version="1.0" encoding="UTF-8" ?>  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

<b:else></b:else>

</b:if>

This Page

has moved to a new address:

http://example.com/wp/blog

Sorry for the inconvenience…

Redirection provided by Blogger to WordPress Migration Service

#3. Place this code in .htaccess file under /wp/ folder (where WordPress is setup)

#Redirect archives  
RewriteRule ^([0-9]{4})_([0-9]{1,2})_([0-9]{1,2})_archive\.html$ $1/$2/ [L,R=301]

Hope above things work for you.

Thanks,
–Nitun


#5

Nitun,

Unfortunately, neither of these things worked =(.

One thing potentially of note: though WordPress is installed in a subdirectory (i.e., /public_html/wp), the URL to the site is example.com not example.com/wp.

Not sure if this makes any difference.

Please let me know if you have any other ideas.

Thanks for all your help!


#6
One thing potentially of note: though WordPress is installed in a subdirectory (i.e., /public_html/wp), the URL to the site is example.com not example.com/wp.

In that case, you can try the .htaccess file in root level of WordPress directory.


#7

Already did. No luck. =(

Let me know if you have any other ideas.

Thanks


#8

Not sure, what is happening there now. Without checking all the settings and code on your blogger template and server, can’t say anything. :expressionless:


#9

Nitun,

You've already been incredibly helpful, but would you be willing to take a look at things on the sites themselves?

Many thanks again!


#10

Drop me an email @ nitun.lanjewar@rtcamp.com, will cross check it.


#11

Hi there,

I am able to redirect all the blog posts to my new site. But it does not redirect static blogger pages to the new site. After applying your generated code to template, after opening any page on blog - it results in blogger error = page not found.


#12
it results in blogger error = page not found.

I think you are using blogspot url with your blog, in that case, you can't redirect the static pages on blogger blog to WordPress blog. Those pages has extra /p/ in their URL.


#13

exelexys and Nitun, Were you ever able to solve this? I’m having the same issue. I goto my blogger.com and it redirect to my website.com but I’d like my blogger.com to redirect to website.com/blog

Sounds like Exelexys was/is having the same issue I am.

Thanks!


#14

Actually, the above code placed into Blogspot template fixed my issue! Thanks guys!


#15

Glad to know that :slight_smile:


#16