Is http/2 browser specific?


#1

I’ve got http/2 configured (default ee settings that come with SSL). I’m on the latest version of Chrome, and I noticed my pages are served with http 1.1 – I also tried the very new Firefox Quantum, and I get the same result there. Using an online tool like GT Metrix or the HTTP2 Tester from KeyCDN, I can see those tools are being served with http/2. How come my browser requests the website using 1.1? Chrome://flags no longer has an option to manually enable 2, so I’m guessing the browser is now supposed to use it by default when it’s available. It’s also odd that the new FF Quantum isn’t using it, when the whole purpose of its release was the major speed bump.

Is there anything else I need to do on the server?

Edit: So it’s not just my website/server. The KeyCDN tester has a list of websites that have been tested, so I clicked on a few that have http/2 supported, but in my browser the websites are being served via http 1.1 – Oh well I guess nothing for me to do but wait for browsers to start using 2?


#2

Currently in Chrome browser there is no more flag that for choosing between SPDY or HTTP/2. Because current version of Chrome is fully transitioning to HTTP/2.

Transitioning from SPDY to HTTP/2

If HTTP/2 stops working for you, it’s probably because NPN has been disabled. The current version of Chrome browser didn’t support NPN.

NPN was similarly revised and released as a new standard called ALPN (Application-Layer Protocol Negotiation). This is a more efficient version with more future-oriented features.

However, on the server side, which runs the webservers that in turn run HTTP/2, there’s a rather practical issue: to support ALPN, you need at least OpenSSL 1.0.2.

See the Protocol Details for for each browser, which had dropped support for NPN. https://www.ssllabs.com/ssltest/clients.html


#3