Installing media node


#1

Hi. I am the owner of an international social network I hoping will be launched this Aug 2nd. We have now encountred a huge problem installing the emdia node for RT Media. I have recently had my developer install RT Media Pro, FFMEG, and the media node for file conversion. Neither my developer or technical team at my web host service provider can successfully get it installed and working. They followed the downloadable install directions, although, state it crashed after running. It is a Linux centos server, with wordpress and buddypress software. Here is a copy of the error message:I have tried executing the following command-line that is given in the URL
https://rtcamp.com/media-node/installation/.

====
curl -sL https://raw.github.com/rtCamp/media-node/master/install.sh | sudo
bash

The command appeared to be working correctly for a long time but then it
threw this error almost towards the end.

====
at Object. (/root/media-node/ffmpeg_server.js:383:24)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
at startup (node.js:119:16)
at node.js:901:3
Error: SQLITE_ERROR: duplicate column name: duration
Error: SQLITE_ERROR: duplicate column name: thumbs

We are not sure about the cause of this error. We would recommend you to
get in touch with the support team for “Media Node” and get their views on
how we can get around these errors and complete the installation of “media
node”.
Any ideas on how to resolve this issue?
Regards,
Scott


#2

Hi Scott,

Just ignore those sqlite errors. Is FFMPEG working properly?
Try uploading video and check this log file /var/log/ffmpeg_server.log


#3

Please give me the following command output:

  
cat /etc/*-release  

#4

Hi… no its not working. FFMEG I mean. It doesnt give any error msgs… just wont upload any video fieles. (avi, wmv, etc etc).
Photos work fine.
In FFMEG settings, when I check the button to see if its installed correctly, it comes back saying that it is.


#5

But it wont upload any video files that arent MP4… any suggesstions?


#6

Hi… ok here is log from the file above that you wanted as well as run of the command line you requested:

Hi,

  1. These are the last messages in the log:

./queued/MOV02926.AVI added to the queue
[]
Processing Queue
Filename : MOV02926.AVI
File info : MOV02926,AVI
Filename without extension : MOV02926
Duration : 2
Max Thumbnails to create : 3
Processing ==> MOV02926.AVI
ffmpeg -i ./queued/MOV02926.AVI -loglevel quiet -r 24 -vcodec libx264 -vprofile high
-preset slow -vf scale=640:480 -b:v 1500k -maxrate 100k -bufsize 200k -threads 1
-acodec libfaac -b:a 128k “./temp/MOV02926.mp4”
stdout:
stderr: x264 [error]: high profile doesn’t support 4:2:2

Execution error: Error: Command failed: x264 [error]: high profile doesn’t support
4:2:2

Processing Queue
file MOV02926 uploaded
mv /tmp/659daeac601d493e7714b0b27e097345 ./queued/MOV02926.
stdout:
stderr:
./queued/MOV02926. added to the queue
[]
Processing Queue
Filename : MOV02926.
File info : MOV02926,
Filename without extension : MOV02926
Duration : 2
Max Thumbnails to create : 3
Processing ==> MOV02926.
ffmpeg -i ./queued/MOV02926. -loglevel quiet -r 24 -vcodec libx264 -vprofile high
-preset slow -vf scale=640:480 -b:v 1500k -maxrate 100k -bufsize 200k -threads 1
-acodec libfaac -b:a 128k “./temp/MOV02926.mp4”

  1. Output of “cat /etc/*-release”

root@ded [~]# cat /etc/*-release
CentOS release 6.5 (Final)
LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
CentOS release 6.5 (Final)
CentOS release 6.5 (Final)
root@ded [~]#


#7

Hi Mitesh and Ritesh. Please resolve this issue asap. We are certainly hoping to be able to provide the RT Media Pro to all the members on the social network Spiritual Chat Rooms housing 40 sub domain community room websites internationally. As soon as the media node issue is resolved I can launch this international social network. Look for us in India as well. I have Community Room websites for both Hinduism, and Sikhism. We believe you can patch up this issue as to why the media node is only converting MP4 files and not the rest. Best regards and wishes, Scott Shaffner Owner/president SpiritualChatRooms.com


#8

Hi Scott,
We had figured out the x264 error. Please run this command on your server and restart the media-node.
sudo wget -qO /root/media-node/ffmpeg_server.js https://raw.githubusercontent.com/rtCamp/media-node/master/ffmpeg_server.js


#9

Hi Ritesh, we ran the command and it still will not support and convert any files other than MP4. I need to ask you if this is issue with media node is common and is happening to other installs? If this Media Node issue cannot be resolved or fixed I am hoping I will be refunded for the RT Media Pro and FFMEG, as I will not be able to use RT Media without the full file conversion. Regards, Scott.


#10

this was a private reply with post_id 68431


#11

here is the last info supplied to us from our host. Can you please advise and supply us with the information they are requesting.

I have checked this and can see that the service is running without any parameters
as shown below

node /root/media-node/ffmpeg_server.js

Can you please check with the support the possible parameters which we need to use
for running the service ? Some of the options are given below.

–use_strict (enforce strict mode)
type: bool default: false
–es5_readonly (activate correct semantics for inheriting readonliness)
type: bool default: true
–es52_globals (activate new semantics for global var declarations)
type: bool default: true
–harmony_typeof (enable harmony semantics for typeof)
type: bool default: false

Also there is no script available for running the service as daemon in the default
installation.
Can you please get this also from them so that we can install it in the server ?


#12

The right syntax to start the server is:

node /root/media-node/ffmpeg_server.js >> /var/log/ffmpeg_server.log &

If you look at htop/top it wont show anything after the >> though, so what your seeing is likely correct. I use it and it works great.

If you ever have to restart the server there’s a “restart” file in the media-node directory that also shows the syntax.


#13

This the last email from the host. Please if anyone,has any suggestions…
I did send the SSH login via private email as well, so please feel free to fix, if you can.

Hi,

The media node is crashing intermittently. Can you contact media node support and
ask them to check this. I tried restarting the media node and it is crashing in
between.

You can check the media checking the process.

==
root@ded [~]# ps uxf | grep media-node
root 7616 0.0 0.0 103252 820 pts/1 S+ 13:40 0:00 _ grep
media-node
root 1756 0.0 0.1 900204 19644 ? Sl 08:08 0:00 node
/root/media-node/ffmpeg_server.js

The best option is to contact RT-camp and ask them to check this.


#14

Is your media node server actually in /root/media-node/ffmpeg_server.js? That’s just the path on my server. It is where ever you installed it.

(I too run CentOS 6.5, same setup as you).


#15

Hi Scott,

To whom you had sent SSH login details? Can you send it to ritesh.patel@rtcamp.com so that we can debug the issue?


#16

The issue with the media node has been resolved. It is running great, and there were no problems with the node. The issue was discovered elsewhere. Thank you to all at RT Camp for your efforts in helping us troubleshoot the problem.


#17

Hi Scott,
I am glad to know that your issue is resolved :slight_smile:


#18