Installation fails on Debian 8


#1

Tried to install EasyEngine V4 on a fresh Debian 8 server. Installation failed with following error message:

-----> Pulling EasyEngine docker images

-----> Pulling EasyEngine docker images

PHP Parse error: syntax error, unexpected '::' (T_PAAMAYIM_NEKUDOTAYIM) in phar:///usr/local/bin/ee/vendor/easyengine/admin-tools-command/src/Admin_Tools_Command.php on line 183

Any idea what went went wrong?


#2

@mrmad Following system was used to reproduce the same error:

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 8.10 (jessie)
Release:	8.10
Codename:	jessie

But the error could not be reproduced. EasyEngine installation completed successfully on the same.

Can you try again in fresh system and give an extensive list of commands you use.
Also, send the logs via mail to ee@rtcamp.com. All the log files are present in /opt/easyengine/logs/ directory.