Install works but not Gitolite Settings or gitolite.sh


#1

I installed the latest active collab 3.2.12 and put ac_gitolite in the custom/modules folder and then proceeded to install it in the modules page. After the install completed I clicked on the 'Gitolite Settings' link per the instructions, but I get the message 'Failed to load page. Please try again later' I thought maybe this is because I have not run the gitolite.sh script yet, so I went into my console, navigated to the ac_gitolite folder,chmoded the script +x and typed 'sudo ./gitolite.sh' This failed with the message 'Unable To Change Directory For Hookspath'. So I looked in the script and noticed it is getting the path from the command line args and I didn't run the script using a full path so I next tried 'sudo /full/path/to/ac_gitolite/gitolite.sh' and this time it failed with the message "Can't create post-receive Hooks !!" and I still can't open the Gitolite Settings page.

My OS is CentOS (which the script detects as RedHat, but should be OK), also my apache server runs using the apache user not www-data from what I can tell.


#2

Fixed the Gitolite Settings issue. The source was the CentOS does not come with the php-process extension and the gitolite plugin uses it. sudo yum install php-process fixed that error and now the Gitolite Settings page loads. Still haven't figured out the gitolite.sh issue yet.


#3

Instead of solving the gitolite.sh script I just went ahead and manually added the post-receive hooks as noted in the installation instructions: "Post-receive hook setup for instant update"


#4

After all this I couldn't get the gitolite plugin test connection to work so I opened the php file and saw the ssh test and realized it was failing because our ssh port is non-standard. Only way I was able to fix this was to hack the script and put in the -p XXXX param to specify the port, now the test connection works but I'm not certain where else I need to add the port specifier. It would be really useful for this plugin to support setting the ssh port as most server admins with security in mind change ports from the defaults.


#5

@petrocket

Looks like you have figured workaround for most of your issues! :-)

Regarding SSH non-standard port number, it is nice suggestion and we will add it in future release. Actually, it will change instructions we display at few places.

For example, commands like following:

git clone git@example.com:testrepo  

will become:

git clone ssh://git@example.com:/testrepo  

There are few more ways to get it working as described here - http://readystate4.com/2011/03/30/working-with-git-repos-on-non-standard-ports/

We met this requirement before but yet to finalize optimal way to deal with it!

If you have any more suggestions/feedback, please send it over. It might get implemented within 2-3 days as we are already making changes to installer.

Thanks. :-)


#6