Inspirebook - "More" Tab problem and suggestion


#1
  • “more” tab does not work, when trying to click on anything that opens under more “hover”, the dropdown disappears, and it’s impossible to click on submenu items.
    I believe it should be closer to the tab, and it should be on “click” not hover, since on mobile devices there is no hover.

Also I would suggest that all tabs should be in one horizontal line (2 lines max) in mobile mode, so “more” tab should be for those tabs that didn’t fit in… (arrow icon would be great next to it)


#2

Sorry for inconvenience, We are looking into it and update you on this asap.


#3

Again, plugin "FirmaSite Theme Enhancer" produced also this problem...

totally my fault,

but the suggestions are still valid :)


#4

Yes, we will definitely take your suggestion in consideration.

Feel free to contact us if you have any suggestion, issue or query regarding InspireBook.


#5

I have a problem with nav tabs in child theme while having rtMedia plugin enabled.
Not sure what it is, but when rtMedia is enabled, “more” appears instead of each tab that should be under “more”. Screenshot attached.

Also I would like to have “more” to appear as LAST TAB in horizontal view (would like to disable multiple lines of the nav tabs and sub navs, in all modes)

  • to have nav tabs horizontal in all modes, mobile etc…
  • To have the last tab “more” if more than 2 tabs could not fit in the horizontal menu.

If this is not possible, could it be set to show “more” tab, if more than 4 nav/subnav tabs are available in mobile mode, and more than 5 tabs are available in tablet mode and more than 6 are available in desktop mode?

Support on this one would be much appreciated…

thank you

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/64503/2014/04/Screenshot-1.png

http://rtcamp.com/wp-content/uploads/rtMedia/topics/64503/2014/04/Screenshot-2.png

http://rtcamp.com/wp-content/uploads/rtMedia/topics/64503/2014/04/Screenshot-3.png


#6

Hi,

My users have same frustrations for this, I guess that the hover timer is too short, user need to be very quick to move the mouse cursor to the submenu, otherwise the submenu disappeared.

This is a quite serious user experience problem, could you fix soon or point out what need to be changed to fix this?

Thanks!


#7

Hello Hanzhidou,

This issue will fix in upcoming version.


#8

How to disable “more” tab?

I would like to have all tabs available at all times… is there a way to disable grouping tabs into “more” tab??

Thank you


#9

Hi,
We are using jQuery for tab grouping. You can try some jQuery stuff for disable grouping.


#10

Thank you for your answer, but is there a way to disable it or not?
If not, please guide me to do it somehow, since it’s bogus.

On the other hand, perfectly would be to set the maximum tabs displayed.
For example: if the maximum tabs displayed is set to 3, whenever there is more than 3 tabs, the 3rd tab should become “more”…
Any help?

Thank you.


#11

Hello Mihail,

There is no option to disable more tab, However you can change it as per your requirement with using of jQuery.

You can use following codes. Add this in .JS file.

var a = jQuery('.rtp-more-menus ul').html();  
jQuery('.rtp-more-menus').parent().append(a);  
jQuery('.rtp-more-menus').remove();

Let me if this helps.

Thanks


#12

nope…didn’t work for me…

but I solved it with changing the n+6 to n+99 … in 2 cases… and it works fine…

Thanks!


#13