Image not uploading in activity stream (Kleo Theme)


#1

Hi guys,

I have tried the different solutions presented so far on the public threads. You went private with another thread that had the Kleo theme. I am using the same.

Yes I have done the typical problem solving techniques concerning plugins and themes. The conflict is with Kleo and you.

audio and video files upload fine but images do not.

Please advise what steps I can take to resolve this conflict.

Thanks!


#2

Hello @pastorduke,

We are not facing any such issue on our demo site, you can also check the same here http://demo.rtcamp.com/rtmedia/

Please check if you are facing any JavaScript error in browser console or in server error-logs.

Thank you.


#3

I found the problem and YES it was a conflict between your plugin and the KLEO theme. I have seen a lot of dismissive responses from your support team on your threads. It turns me off from upgrading to RTMediaPro

function kleo_rtmedia_modify_upload_params_upload_url( $params ){ if( class_exists( ‘BuddyPress’ ) && bp_displayed_user_id() && bp_is_activity_component() ) { $params[‘url’] = site_url() . “/” . bp_get_activity_root_slug() . ‘/upload/’; } return $params; } add_filter( ‘rtmedia_modify_upload_params’,‘kleo_rtmedia_modify_upload_params_upload_url’, 10, 1 );


#4

Hello @pastorduke,

Sorry for the delay in reply. As you had created this topic without selecting category, hence we missed your query. We are active on community support for rtMedia here http://community.easyengine.io/c/rtmedia kindly follow the category selection for your further queries.

May I know for what specific reason you have added above code?

Thank you.


#5

I added that code to solve the problem stated in the title of this thread. The image was not uploading in the activity stream with the KLEO theme. There was another user that had the same problem but you guys took the thread private so I could not find the solution in that thread.

Your response to me was what I see a lot of here on this support forum. “We don’t have a problem, it is your issue.”

I finally found the solution and yes it was a conflict between your plugin and the KLEO theme.

I posted the solution.

Now can I tell you why the code works? No, I am not a coder which is why I reached out for support. I just know that it does work.

I run a niche social network. I am looking for a solution that adds the ability to post links with previews without using 2 plugins and also adding capabilities to audio and video file uploads. You guys have the solution however I am not interested in paying $149.00 just to get a response like I was given. I need support, not “the problem is not ours.”

Anyways, now you have the code that I had to search high and low for. Please make it available for the other KLEO theme users that are trying to find a solution to the conflict.


#6

Hello @pastorduke,

We suggested you so because it is our standard procedure to first check plugin with WordPress default themes and other plugins disabled to identify whether the issue relates to rtMedia or its a conflict. Many times it is theme/plugin issue and misguide us in debugging the issue.

And for the other thread with private reply, we took user to private thread because our team cross check user site for issues and user shared his site login details with us. Which we can’t make it public. As Kleo theme is compatible with rtMedia plugin, hence its a strange things that user facing issues and come up with conflict. We are always here to provide free support, but if you check most of the support threads where issues pointed are mostly related to other plugin’s JS conflicts.

Thanks for providing the solution here, its a community forum. I hope your solution helps other users as well.

Thank you!


#7

That is why I stated in my original post.

Maybe I wasn’t clear, and if so that is my fault. However to respond after I had made that statement with

was not helpful.

Thank you


#8

@pastorduke

I am having the exact same problem with the Kleo Theme. Could you tell me exactly where to put that code that you provided?

Thanks.


#9

Appearance > Editor > Theme Functions (functions.php)

Or you can do it the hard way through ftp or file manager depending on your hosting environment.


#10

Hi, if you are using WPML then this should be fixed in later rtMedia updates. Also here is the fix to this: WPML and rtMedia activity media upload problem


#11

Hello Everyone,

I have the same issue. When I’m uploading a photo from my Activity Profile, it’s not working, but when I use the Global Activity Stream it works. I’m using the Kleo theme BUT, I changed to Twenty fifteen and I got the SAME issue.

Adding the code in function.php mentioned in old posts didn’t work for me. Do you have any advise?

My configuration is:

WordPress Multisite: 4.1.1 BuddyPress: 2.2.1 rtmedia: 3.7.35

Kind Regards,


#12

Hello @luczar,

Can you check whether BuddyPress JavaScript file ( buddypress.js ) is getting loaded on Activity Profile or not? ( You can find it from sources tab under browser console of activity profile. )

If you are using wpengine hosting and BuddyPress JavaScript file is not getting loaded on profile page then you can give it a try by unchecking the “Activity auto-refresh” feature in BuddyPress settings. Refer this support ticket for further details https://buddypress.org/support/topic/buddypress-js-not-loading/

Hope this will help you. Thank you.


#13

Hi,

Thanks for your advice. I send you an image from my browser console. I’m using my local machine with Linux.


#14

I had the same issue. I am also using KLEO theme and end up with the problem where rtMedia upload button was not working in activity stream or even in albums. I searched everywhere and here I found that a solution to put some code in functions.php. I was about to test this problem, but somehow I managed to remember one problem previously I had with some other site , which was a Javascript Conflict issue.

And yes in my case it was Javascript issue. Not exactly it needs to be conflicted. If javaScript warning or error for any code of any other plugin or of your custom javaScript is there, which may not be related to rtMedia, but some other code, will make this rtMedia plugin fail to work. I added this reply so that users can look into this problem if having this issue before tweaking some code. Mine was a custom javaScript which was meant to put for one single page, but I put it in KLEO theme options general settings, for that reason this javaScript thrown an error for all pages other than the page it required. I just removed it from that place . After that this issue was resolved.


#15