HTTPS SSL Challenge DNS Fail (OVH)

Good morning, sir,
I’ve got two VPS, one for production and one for testing.
The second VPS of dev to a copy of the site in production for me to do my tests.
So I use the same command to create my site ( cf : ee site create … )
On the production server no problem my site runs in HTTPS the challenge dns worked the first time etc…
On the server of dev no problem if I don’t activate the HTTPS…
Recently I reinstalled my dev server and I tried to recreate the dev site in https.
Impossible, I added the DNS challenge but it blocks…
Attached is a screenshot of my configuration at OVH.
I have added TXT entries in addition to the _acme-challenge sub-domain.
The command host -t TXT returns the right value…
I don’t use cloudflare.
Do you have an idea.
ps: logging gives me nothing more than “it doesn’t work”.
Thank you in advance for your help.

My config OVH

I have reinstalled my VPS and reset my dns entries in ovh and it works.

You shouldn’t need to manually make any DNS entries, as long as there is an ‘A’ record pointing the URL to the address of the server. You can have multiple IPs in a record.

But that would mean half of the traffic for the main site would go to the prod site. Unless you add the IP, get the certificate installed, then remove the IP from DNS. But for that, you’ll need a hosts file entry to access the site.

Better thing to do is make the test site use a different name, like prefix it with dev. ( and