HTTPS: “siteurl” and “home” in WP database should use https not http


#1

The EasyEngine installation sets up the website to be served with https which is great. It even includes Nginx configuration to redirect http to https.

The one thing I have discovered which has caused me problems is with the Wordpress installation. In the “wp_options” table in the Wordpress database, the “siteurl” and “home” is not using http. Sometimes this is causing problems so I cannot access the site. After every new installation I must go into the database with phpMyAdmin and change the links. For example: http://mysite.com to https://mysite.com.

If you are able to log into Wordpress it’s easier to make the changes in the Wordpress settings: Settings -> General -> Wordpress Address (URL) Settings -> General -> Site Address (URL)

If this is a bug I hope it can be fixed in the next release.


#2