How to disable redis cache safely? --cache

Huy guys,

I would like to disable redis cache safely, I tried disable it by **ee service disable redis** but, it seems making site extremely slow and shows php errors when I reload the service"

2020/07/14 08:34:06 [emerg] 46#46: host not found in upstream "global-redis:6379" in /usr/local/openresty/nginx/conf/conf.d/main.conf:9

nginx: [emerg] host not found in upstream "global-redis:6379" in /usr/local/openresty/nginx/conf/conf.d/main.conf:9

nginx: configuration file /usr/local/openresty/nginx/conf/nginx.conf test failed

. Can anyone please tell me how to disable redis cache safely?

Thanks

Comment the following lines in main.conf file located here: /opt/easyengine/sites/site-name/config/nginx/conf.d/main.conf

              srcache_fetch_skip $skip;
		srcache_store_skip $skip;

		srcache_response_cache_control off;

		set_escape_uri $escaped_key $key;

		srcache_fetch GET /redis-fetch $key;
		srcache_store PUT /redis-store key=$escaped_key;

		more_set_headers 'X-SRCache-Fetch-Status $srcache_fetch_status';
		more_set_headers 'X-SRCache-Store-Status $srcache_store_status';

Then run:

ee site restart site-name.tld --nginx
1 Like

Thanks for direction, already figured out thought :slight_smile: