How to disable MariaDB binary log safely and permanently


#1

MariaDB binary log is taking almost 10GB now on my VPS. I removed logs and added a setting to my.cnf to disable the binary log, however, after EE update my.cnf got reset and now my HDD is full.
How to disable logs permanently?


#2

Comment out all the lines on

/var/lib/docker/volumes/global-db_db_conf/_data/conf.d/ee.cnf

and only the log_bin, log_bin_index, expire_logs_days, max_binlog_size from

/var/lib/docker/volumes/global-db_db_conf/_data/my.cnf

#3

It looks like it worked - however, won’t ee.cnf be overwritten when doing ee cli update?


#4

I am not quite sure because I also changed it recently and there aren’t any updates since I changed it. Maybe it will ask whether to overwrite with the new version or keep the installed version but that’s just my guess. I haven’t found any other option to disable it. So, if the settings are overwritten, the only option we have is to repeat the process.