How not to redirect access to IP for the domain? 🤔


#1

Hello everyone, I need your help.

On my website, I run a script that needs to be accessed externally via the POST method.

In the previous version (V3), I just deleted “force-ssl-domain.com.conf” file from “/etc/nginx/conf.d” and added “listen 80;” in the domain configuration file inside the “/ etc / nginx / sites-available” directory.

But now that everything has changed, I do not know how to access the script by IP on the machine on port 80. When I try to access “X.X.X.X / script.php? Ver = 1” I am redirected to my domain. Could anyone help me find a way to access my script over IP? :sweat_smile:

Thank you for your time. :blush:


#2

Good night people.

I’ve tried some settings but so far unsuccessful. I have already changed the settings in the redirect file of the “/ var / lib / docker / volumes / global-nginx-proxy_confd / _data /” folder. I removed the redirect “listen 80” and now when I try to access the script through IP, I get the error message 404.

Anyone with more experience in Nginx could give me a way to try a solution? It’s been 2 days since I’m caught up in this issue. I imagine it’s something simple for anyone who understands Nginx.

Thanks for your attention one more time.