How do I access the / app / htdocs / files directory in EE4, does anyone know how to do this?


#1

How do I access the / app / htdocs / files directory in EE4, does anyone know how to do this?

How to access the / app / htdocs directory using the FiliZilla FTP client?

The / app folder has permission of type lrwxrwxrwx / folder of type link or shortcut.

Access via ssh works 100%, and when I use the FileZilla FTP / SFTP client I can not access the app / htdocs directory.

How does this work in practice, how to solve this, does anyone know?

For God’s sake, do not post tips that are on other topics, I’ve done all the examples cited by collaborators.

Does anyone know how to access the / app / htdocs folder using FileZilla FTP client?

Is there another format to do this?

Is this the right way?

Grateful!

Att. Flávio Igino


#2

Permissions seem to need a bit of work on v4.0.6.

As well as other suggestions, like setting access & ownership on app/ directory, make sure you have also set execute permissions on the /var/lib/docker/volumes directory so it can be traversed. This is needed because the app/directory is symlinked to a directory inside /var/lib/docker/volumes.

These commands below will allow traversal for the www-data group, but you might want to use a different group like admin or sftpuser:

chmod g+x /var/lib/docker/volumes
chgrp www-data /var/lib/docker/volumes


#3

Thanks Rob, I was missing the docker volumes part!

I ran sudo adduser morgan www-data
chmod g+x /var/lib/docker/volumes

I can now access and edit the files :blush:


#4

I would like to create an sFTP/FTP user for each project on our fresh installation of EE4. Do you have any link guide or tutorial? I followed the EE3 tutorial, but I am still not able to access through FTP client.
My best


#5

It did not work on my server. I still can not access the folder via Filezilla.

Do you have another suggestion?