How can I install PHP 5.4?


#1

Hey guys,

I have a new install of EasyEngine and I need PHP 5.4 - how can I install that?

EasyEngine installed 5.6, 7.0, 7.1 and 7.2 for me.


#2

Hello,

What is the distribution on your server ?


#3

I use Ubuntu 14.04 64bit LTS.

I did read a few threads that PHP5.4 needs Ubuntu 12.04LTS but I’d like to get it working with 14.04.

And I know 5.4 is insecure but the client needs it and his theme is incompatible with php 5.6 or greater.


#4

You can add the PPA repository to install php5.4. :

sudo add-apt-repository ppa:ondrej/php5-oldstable
sudo apt-get update

sudo apt-get install -y php5

#5