HHVM issues after last upgrade. How to disable/remove?


#1

Hi all!

I have tried using HHVM on my server and monitor it with Monit, but after the upgrade I experience a white screen on both on front and back end from time to time. It seems this has to do with HHVM restarting (with the help of Monit).

Anyway, I would like to use HHVM and hope that it will be more stable in future releases (and more compatible with WordPress), but for now I would like to disable / remove it from my setup.

Could someone tell me the necessary steps? I’m a bit too new on this to have the guts to do it without guidance. Don’t want to crash something :slight_smile:

Take care and thanks a lot!

// Jens.


#2

First you should ensure your site does not use HHVM anymore:

ee site update example.com --wpfc

This should be enough to stop your white screen of death issues.

If you want to go one step further you can remove HHVM from your system:

ee stack remove --hhvm

How else could we assist you? :slight_smile:


#3

Hey @janiosarmento thanks for your help! Unfortunately, after doing this, all that happens when I visit my site is that a file is downloaded, containing the wordpress headers:

<?php
/**
 * Front to the WordPress application. This file doesn't do anything, but loads
 * wp-blog-header.php which does and tells WordPress to load the theme.
 *
 * @package WordPress
 */

/**
 * Tells WordPress to load the WordPress theme and output it.
 *
 * @var bool
 */
define('WP_USE_THEMES', true);

/** Loads the WordPress Environment and Template */
require( dirname( __FILE__ ) . '/wp-blog-header.php' );

The site in question: delbart.se


#4

I used a server snapshot to reset the server to previous setup, but there is something fishy with my easyengine setup. How can I trouble shoot this?


#5

What’s the result of:

ee site info delbart.se

(You should, of course, omit your passwords or other sensitive data.)


#6

Hi again @janiosarmento, I really appreciate your help!

This is what I get from this (right now it’s reset with HHVM active again of course):

Nginx configuration	 wp basic (enabled) 
Pagespeed		 enabled
HHVM			 enabled
access_log		 /var/www/delbart.se/logs/access.log
error_log		 /var/www/delbart.se/logs/error.log
Webroot			 /var/www/delbart.se

#7

This command does NOT seem to completely remove HHVM from the stack.

How can HHVM restart if it has been removed?


#8

Try:

ee site update delbart.se --hhvm=off

#9

I can’t answer that. I’m just an user trying to help other users, nothing else.


#10

The result of the command:

ee site update delbart.se --hhvm=off

…is…

HHVM is allready disabled for given site

Interesting it says disabled, and not “does not exist” or something to that nature.

I know - just thought you may have some insight.


#11

Hi @jensfilipsson

Please try the latest EasyEngine. Use ee update to upgrade your current EasyEngine version to the latest.

I hope your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#12