Help! my site is directing to another site


#1

hi,

after apt-get update on debian 8, I get 525 error for one of my site on SSL.

When i disabled it (via --letsencrypt off), it strangely, when i try to open that site, it opens another site on my vps.

how can i correct this?

how can i correct 525? and also why my site is loading another site?

site name is: pratikk.net


#2

Ok new update. 525 error was for my every sites using cloudflare. but i couldn’t see it first because i chose always on for them.

So I have to deal 1 site for 525 errors and 1 site getting wrong certificate.

What is the correct steps to stop 525 error ?

And what could be the appropriate steps to stop getting certificate of another site?

Thanks,


#3

If you turn off letsencrypt, then trying to access the HTTPS version of the site would redirect you to a different domain that has HTTPS enabled. This domain is the one you’ve already setup as the reverse DNS (Linode > Remote Access > Reverse DNS). So that’s a normal behaviour.

If you want to disable letsencrypt and continue using the normal HTTP version of the site, then you need to change the URL settings in the wordpress (WP Dashboard > General).

If you are not able to access WP dashboard via browser, you can edit the functions.php file of the active theme and add the following lines, immediately after the initial <?php line :

update_option( ‘siteurl’, ‘http://yourdomain.com’ ); update_option( ‘home’, ‘http://yourdomain.com’ );

Location (functions.php):

/var/www/yourdomain.com/htdocs/wp-content/themes/your_theme_name/functions.php

Once you get access to the WP dashboard and change the Site URL and Wordpress URL from https to http, you can remove those 2 lines added to functions.php.

Now you can use the site as a normal HTTP version. And if you ever want to re-enable letsencrypt, simply login to wordpress dashboard and change the URLs to HTTPS.

Hope that helps…


#4

thanks for detailed reply and reaching ouy. although this will be good reference or the functions.php workaround, i don’t have any setup regarding to reverse dns.

i removed my site from cloudflare first.

since i believed, easyengine just creates necessary config files and certificates for the first time. and since it was working until debian update, i thought the certificates can be generated again without easyengine. with more manual method.

Then i generated new certificate by choosing web server and OS and applying the necessary steps from this link below.

and certificate is generated successfully.

but it was again wrong site direct. i duplicated a working site configs and changed sitenames with the and voila! site started to work.

then i check again with the command

openssl s_client -servername example.com -connect example.com:443

it was ok.

and it seems at the end it was nginx mumbling about conf files.


#5