Having problem www. Added websites


#1

If I visit https://islamqabd.com . It’s going to my 1st website . But if I put www. Before the domain , then it’s working .


#2

I have this problem as well. I found it really hard to implement a solution on NginX. It is much easier with apache.

I solved it by using a DNS service that has a web redirect option in the DNS settings.


#3

You seem to have solved your problems?
In my situation, I’ve solved all the problem related to www/non-www redirect with EEv4.0.10 by the following steps:

  1. Open and check the file

/opt/easyengine/services/nginx-proxy/conf.d/yourdomain-redirect.conf

Check if the server name is correct, there are two lines of server name (http and https)

My domain name starts with a “w”. It was abandoned thus wrong name!

Make sure ssl_protocols including all version of TLS

ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3;

It IS included in the file:

/opt/easyengine/sites/www.yourdomain.tld/config/nginx/nginx.conf (/var/lib/docker/volumes/wwwyourdomaintld_config_nginx/_data/)

But not this file

By default, EasyEngine does not include TLSv1 TLSv1.1 or SSLv3, this may causes error 503 when someone just type “yourdomain.tld” in the browser address bar when your site was created with SSL + Wildcard + sub:WWW

Also make sure other ssl settings similar.

Hope it help.