Have error Unable to clean opcache


#1

hello. i clean cache but have error. please help me. thanks ee clean --all Restart : memcached [OK] Cleaning MemCache Cleaning NGINX FastCGI cache Cleaning opcache Unable to clean opcache Cleaning Redis cache


#2

log 2016-12-05 18:40:31,907 (INFO) ee : Cleaning opcache 2016-12-05 18:40:31,912 (DEBUG) ee : <urlopen error [Errno 111] Connection refused> 2016-12-05 18:40:31,912 (DEBUG) ee : Unable hit url, https://127.0.0.1:22222/cache/opcache/opgui.php?page=reset, please check you have admin tools installed 2016-12-05 18:40:31,913 (DEBUG) ee : please check you have admin tools installed, or install them with ee stack install --admin 2016-12-05 18:40:31,913 (ERROR) ee : Unable to clean opcache


#3

and i install : ee stack install --utils Downloading phpMemcachedAdmin [Done] Downloading clean.php [Done] Downloading opcache.php [Done] Downloading Opgui [Done] Downloading OCP.php [Done] Downloading Webgrind [Done] Downloading pt-query-advisor [Done] Downloading Anemometer [Done] Destination path ‘/var/www/22222/htdocs/php/webgrind/webgrind-master’ already exists

and ee clean --all Restart : memcached [OK] Cleaning MemCache Cleaning NGINX FastCGI cache Cleaning opcache Unable to clean opcache Cleaning Redis cache


#4

:frowning: still error


#5

help me


#6

Don’t worry about opcache, the default php config doesn’t set opcache enabled. And you should not need to use --all, opcache is only for php process caching, it doesn’t impact your website cache.


#7

i use: ee site create gamestua.com --wpredis --php7 how to use opcache for my site thanks


#8

Simply add the following code after [opcache] in /etc/php/7.0/fpm/php.ini

opcache.enable=1
opcache.enable_cli=0
opcache.memory_consumption=256
opcache.interned_strings_buffer=4
opcache.max_accelerated_files=20000
opcache.max_wasted_percentage=5
opcache.validate_timestamps=1
opcache.revalidate_freq=2
opcache.optimization_level=0xffffffff

#9