GoDaddy not receiving emails


#1

I’ve called GoDaddy support many times on this, and they have no idea what it is. Maybe the community can help…

My setup:

  • ee on ubuntu 14.04
  • AWS EC2 instance
  • WordPress site + GravityForms for “contact us” page

The problem: When a user submits the contact form, notification emails are successfully sent to all emails, but not GoDaddy hosted email accounts.

I’ve already made sure the emails are not in the spam folder, I’ve added the email, domain and IP address to the “whitelist” area in GoDaddy settings. Customer support didn’t really help much either.

Now I’m thinking it has something to do with OpenDKIM but I’m pretty new to that.

How can I troubleshoot this? Is OpenDKIM an issue I should be looking into?

tl;dr GoDaddy email hosting doesn’t receive emails when sent from my WordPress site on EasyEngine. How do I fix that?


#2

Hi @THORR can you please send me the outputs of the following two commands :

mailq

and

cat /var/log/mail.log


#3

Hi Rajdeep,

I checked with GoDaddy and they do not require DKIM to receive email on their servers. Nonetheless, they still couldn’t help me :\

In doing more research into the mail logs, I discovered that the error is [550 IB506] in mail.log:

550 5.2.0 From: Domain is invalid. Please provide a valid From: IB506 http://x.co/srbounce (in reply to end of DATA command)

GoDaddy has some documentation on the matter, which indicates that the MX records are invalid (https://support.godaddy.com/help/article/3568/what-does-my-email-bounceback-mean). However, when I check the MX records using online tools, there appears to be no errors, and GoDaddy told me that they were set correctly (at this point I’m not sure if they really know that).

Here’s the output of what you asked for:

mailq

Mail queue is empty

cat /var/log/mail.log | grep bounced (Only showing the last line)

Mar 25 15:40:16 ip-172-30-1-234 postfix/smtp[937]: E8C3B80F47: to=godaddyemail@customdomain.com, relay=smtp.secureserver.net[68.178.213.37]:25, delay=0.8, delays=0.01/0.01/0.52/0.26, dsn=5.2.0, status=bounced (host smtp.secureserver.net[68.178.213.37] said: 550 5.2.0 www-data@ip-172-30-0-105 From: Domain is invalid. Please provide a valid From: IB506 http://x.co/srbounce (in reply to end of DATA command))


#4

Hi @THORR inferring from your mail logs , the problem may be :

Issues during DNS lookup when the email was sent.


#5

Well, we solved it by moving to a different email provider. Thank you for your help!


#6

I’d like to post another update to how I was able to solve this issue - not just by moving to a different email provider - but actually fixing the issue. I won’t go through how I did this, but I will list what I did:

  1. Set up Reverse DNS (rDNS) for the hostname that my server was using. My hostname was not a FQDN, so I had to change it to one that I owned (and change other settings in postfix to match my new hostname). I needed to contact my VPS hosting provider to set up the rDNS settings for my domain name
  2. Set up a Sender Policy Framework (add a TXT record to your DNS settings) - learn more here: http://en.wikipedia.org/wiki/Sender_Policy_Framework
  3. Optional: DKIM (I didn’t need to do this, but thought I’d include it for those who might need it) http://www.dkim.org/

Hint: if you can view the raw form of the email sent, you can check the headers to see if the SPF was a “pass” or “fail” and other useful information. i.e in Gmail, choose “show original” in order to see this info.


Mail w/ multiple domains - mail server host name
#7

@THORR glad to know your issue is solved and thanks for sharing your workaround.

I have covered my checklist here - https://rtcamp.com/tutorials/mail/fqdn-reverse-dns-ptr-mx-record-checks/

And some tests here - https://rtcamp.com/tutorials/mail/server/testing/


#8

Hi @THORR

Thanks for sharing the fix, this willcertainly help the community when facing similar issues.

I am closing this support topic for now, as the issue has been resolved.


#9