Full page caching with redis


#1

I get this when i check the header for my site:

X-SRCache-Fetch-Status: MISS X-SRCache-Store-Status: BYPASS X-Powered-By: EasyEngine 3.7.3

Are the pages getting cached? How can I check or force it? It was done on a clean install.


#2

Redis doesn’t make full page caching, it only does object-caching


#3

Doesn’t this say it does?


#4

You can does page caching with redis, but easyengine use the plugin redis-object-cache which does only object-caching


#5

What’s your domain name?

Make sure your wp-config.php file has the following line in it:

define( 'WP_CACHE_KEY_SALT', 'yourdomain.com:' );

and then in WP admin go to Settings -> Redis and make sure Object Cache is enabled. One other thing make sure Redis cache is selected as your caching method in Settings -> Nginx Helper.


#6

X-SRCache-Fetch-Status: HIT X-SRCache-Store-Status: BYPASS X-Powered-By: EasyEngine 3.7.3

it’s showing this now on the main page. Does that mean there was a hit but bypassed it??


#7

First time it has HIT and Store status BYPASS, then after some time it will store it so you will get Fetch-Status: MISS (it’s already stored) and Store-Status: STORE. So it’s normal behavior, your Redis Cache is working fine.


#8

X-SRCache-Fetch-Status: HIT means the page was fetched from the cache. Yay! X-SRCache-Store-Status: BYPASS means the request doesn’t need to be stored in the cache (it’s already there)

X-SRCache-Fetch-Status: MISS means the page is not cached


#9

thank you very much! Glad to know it’s working!


#10