Fresh install but 502 / Problem Connecting to site! when I create a website

Good morning, everyone,

I have just registered on the site because I did not find a concrete answer on this forum or on gitlab.

this is my problem:

I have a dedicated server at OVH (Kimsuffi)

it’s been 10 times that I’ve tried to make my wordpress site work with “easy engine” v4.

With the V3 everything works except SSL.

here is my configuration:

Ubuntu Server 16.04 “Xenial Xerus” LTS (64bits)

Sorry for my English, I’m French.

So I installed the latest version of Easy Engine with this command line


wget -qO ee https://rt.cx/ee4 && sudo bash ee

IP 37.18X.XXX.XXX

I have a domain name at ovh for example: test.mydomain.fr with a dns redirection “A” on the ip of the Kimssufi server :

IP 37.18X.XXX.XXX

and I create my wordpress site with this command line

ee site test.mydomaine.fr --wp --dbuser=myuser --dbpass=mypassword --dbname=mydbname --user=myusername --pass=mypasswordwp [--email=contact@mydomaine.fr](mailto:--email=contact@mydomaine.fr) --dbprefix=myprefix_

and here are the logs:

17-07-2019 18:02:23] ee.DEBUG: COMMAND: docker-compose exec php mv /var/www/htdocs/wp-config.php /var/www/wp-config.php  
[17-07-2019 18:02:28] ee.DEBUG: RETURN CODE: 0  
[17-07-2019 18:02:28] ee.DEBUG: -----------------------  
[17-07-2019 18:02:28] ee.INFO: Moved /var/www/htdocs/wp-config.php to /var/www/wp-config.php successfully  
[17-07-2019 18:02:28] ee.DEBUG: -----------------------  
[17-07-2019 18:02:28] ee.DEBUG: COMMAND: /bin/bash -c 'echo "127.0.0.1	test.mydomaine.fr" >> /etc/hosts'  
[17-07-2019 18:02:28] ee.DEBUG: RETURN CODE: 0  
[17-07-2019 18:02:28] ee.DEBUG: -----------------------  
[17-07-2019 18:02:28] ee.INFO: Checking and verifying site-up status. This may take some time.  
[17-07-2019 18:02:29] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:31] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:33] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:35] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:37] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:39] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:41] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:43] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:45] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:47] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:49] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:51] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:53] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:55] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:57] ee.DEBUG: test.mydomaine.fr status httpcode: 502  
[17-07-2019 18:02:59] ee.DEBUG: test.mydomaine.fr status httpcode: 502  

I anonymized the fieldsI anonymized the fields

Thank you for your help

full logs : https://www.codepile.net/pile/p874dgGl

When I go to test.mydomain.fr I am sent to a holding page from your provider. Pinging it tells me the URL is pointing at 194.206.126.204. I assume you haven’t removed the forward or the DNS hasn’t updated. At least that’s what I am seeing on my end. I hope this helps.

Test.mydomain.fr is a exemple. You can’t try with test.appypole.fr

If you use ee site list does test.appypole.fr show up on the list exactly as your domain?

+---------------------+---------+
| site                | status  |
+---------------------+---------+
| test.appypole.fr    | enabled |
+---------------------+---------+
Error No sites found!

because :
ee remove my site after my command to create

[17-07-2019 18:04:49] ee.INFO: [test.mydomaine.fr] site root removed.  
[17-07-2019 18:04:49] ee.INFO: Site test.mydomaine.fr deleted. 

Configuring project.
Creating WordPress site test.appypole.fr
Copying configuration files.
Starting site's services.
Downloading and configuring WordPress.
Moved /var/www/htdocs/wp-config.php to /var/www/wp-config.php successfully
Host entry already exists.
Checking and verifying site-up status. This may take some time.
..............................................................
Warning: Problem connecting to site!
Warning: Initiating clean-up.
[test.appypole.fr] Docker Containers removed.
[test.appypole.fr] site root removed.
Site test.appypole.fr deleted.

serveur-3

when ee try to connect I’have a 502 and after remove container I’ve 503

Sounds like you have a stuck container or something. Never really seen that before. Since you are on a VPS I would recommend simply destroying it and remaking it and setting up EE4 again. Also, I would recommend setting up your VPS with Ubuntu 18.04 instead of 16 so you have the latest version EE works with, less mess later.

On a side note, if you wouldn’t mind telling me, how much does a server like that cost with Kimsufi? I personally use Digital Ocean myself. Personally, I feel your server is overkill for Wordpress, especially WP on EE4. My server has the min you can get with Digital Ocean, 1 GB | 1 CPU | 25 GB SSD disk | 1000 GB transfer a month. It is $5 a month and I have stress tested the server with up to 10000 visitors concurrently without any issues. I gave you my referral link in case you wanted to try it. They give you $50 worth of credits to play around with. I personally love their service. https://m.do.co/c/95b7287681e2

Hello,
it is not a VPS but a dedicated server. It costs me about 4€/month.
It’s not just going to be used for the site.
I’ve reinstalled it 23 times…
Thank you for your help.

I’m upgrade my ubuntu 16 to 18 and test

I have the same problem … with 18

Please help me … :confused:

I’m Solve my problem I take VPS with OVH not Kimsuffi Maybe it’s a DNS problem.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.