Finally making the upgrade need help


#1

Migration script proved to be useless. Onto new server. Chose Ubuntu 18.04. Actually that’s not true. Chose debian 9 but after failing to get bash completion working as sudo user I assumed rtcamp preffered ubuntu.

Nope cannot get tab completion working as my user with sudo privileges. For starter there is no longer a .bash_profile file. Not a big deal added it to .profile. Still doesn’t work as I would expect.

Can someone explain to me why I am getting

Error: Config root: /opt/easyengine is not writable by EasyEngine

I run only a handfull of sites and since http/2 is broken on my v3 server I decided to take the time. Just wasnt planning on every step to be a hassle.

Should I just be logging in as root? If so why is there sudo in the install command. Is there something else I should be doing that is plainly clear to seasoned admins?

any insight as to why following the instructions are failing would be a big help

regards


#2

This is only a guess but I do almost everything as root. There is a good chance that will solve your problem. It seems similar to msgs I get when running commands not as root.


#3

Thank you for the quick reply. I will su root once I am in.

Out of time for the day. Will proceed tomorrow.
:grinning: