Favicon.ico not being displayed


#1

Once again, I deployed Nginx+WordPress using easyengine. You guys created a beautiful thing. And since you guys are sort of like nginx+wordpress /EXPERTS/, I figured I would ask you guys here for some more help. I have in my and it refuses to load the favicon.ico. So I checked the nginx locations file and It see that it is stated in there. I then also added an alias in that /favicon.ico block that points to /var/www/mydomain.com/htdocs/favicon.ico. Still doeesn’t work. If I go to http://mydomain.com/favicon.ico, the file is there and visible.

(P.s. if you guys have a donation link somewhere I would love to show my gratitude)

Thank you,
AJ


#2

Never mind! “Sudo service nginx restart” solved the problem!


#3

@adriano-cortereal

Glad to know that it worked. :slight_smile:

We ourself forget to reload nginx config many times after changes. We in fact planning to add a workaround for this.

easyeneinge already uses git version control to track config changes. So whenever there are uncommitted changed, it will prompt if it (easyengine) can test changes (nginx -t) and reload them (service nginx reload).

Also in that case, easyengine will do git commit behind the scene.

Regarding donations… thanks for asking. :slight_smile:
You may donate from - http://rtcamp.com/donate/


#4