Fatal error (I use the last version that is available for download)


#1

I use Wordpress, Buddypress, and BP Media Component latest version and get this error when trying to activate the BP media component plugin:

El plugin no ha podido activarse porque ha provocado un error

fatal.

Parse error: syntax error, unexpected ‘)’, expecting ‘(’ in /home/darkcvltv/domains/gothicnet.co.cc/public_html/wp-content/plugins/buddypress-kaltura-media-component/bp-media.php

on line 80

Here are the lines in my bp-media.php file from 80 to 92:

        $ks                     = $client->session->start(get_site_option( ‘bp_rt_kaltura_admin_secret’), ‘ANONYMOUS’, KalturaSessionType::ADMIN);
        $client->setKs($ks);  // set the session in the client

        $kaltura_validation_data =
                array(
                ‘partner_id’            => get_site_option(‘bp_rt_kaltura_partner_id’),
                ‘subpartner_id’         => get_site_option(‘bp_rt_kaltura_subpartner_id’),
                ‘admin_secret’          => get_site_option( ‘bp_rt_kaltura_admin_secret’),
                ‘secret’                => get_site_option( ‘bp_rt_kaltura_secret’),
                ‘partnerUserID’         => ‘ANONYMOUS’
        );


#2

Hey Louis,

Its working fine @ my end. (With Both wp and WPMU both 2.9.2).

Please download again from WP

plugins repo.

The snippet of code you have given is definitely NOT on line number you

have mentioned!

Please also mention what version you are using (both BP + WP/WPMU).

We soon going to release new features like Privacy, Media Album, Photo

tagging etc…So stay tuned :wink:
 


#3

I use

wordpress 2.9.2
buddy press 1.2.3
buddypress-kaltura-media-component.1.2.1

I dont have anymore plugins installed, the folder in my plugin directory are of BP, BP media component and the akismet plugin…

Tried to activate again the plugin that I downloaded from the link that you given to me

and get the same error, but in diferent line

Parse error: syntax error, unexpected ‘)’, expecting ‘(’ in /home/darkcvltv/domains/gothicnet.co.cc/public_html/wp-content/plugins/buddypress-kaltura-media-component/bp-media.php

on line 95

I only have buddypress activated, what I doing wrong?


#4

or MU is a requirement? because I don’t have MU installed…


#5

I’m having trouble installing BP Media on a regular WP install too.  I’m not getting an error message but can’t upload/view any media.  I’ve gotten all the correct Kaltura accounts etc. but the BP media screens show the admin login pages inside. 

Is WP MU required?  Is this a known bug?


#6

Hi Louis
I had exactly the same problem and error message and found your post last night. I spent the whole day yesterday trying to figure out what the problem was. I tried a few things out and it dawned on me that the version of PHP I had on my shared server was way behind what the hosting company said I had installed.

After a strong email to the hosting company, and with PHP updated to 5.2.9, the plugin is now working fine, so check that your version is the latest:)


#7

I am getting exactly the same error message and the lines of code (from line 80 ) are identical to those written above. I’m using WP 3.0 and BP 1.2.5


#8

Hi Traceyc,

The BP-Media Component has not been updated for WP3.0 yet. We will let you know about its release by this weekend. Stay tuned on http://mediabp.com/
Thanks

#9