Fastcgi cache and style.css - Can't purge


#1

Hello.
I’ve ran into a problem with the fastcgi cache.
Everything is working perfect, as I setup wordpress with nginx via easyengine.
However, I have got a problem with caching of CSS files.
If i open my website from another browser, which i dont use much, it will load a months old version of style.css. It only loads the new style.css if I press f5. However, I am sure, that most people that view the website do not know how to press F5, and I can’t tell every single one of them to do that. So, recently I made a new wordpress widget with changes in my theme’s style.css, it loads the widget without refreshing the page, however its totally broken, since it doesn’t load the new style.css before i press f5. So, I just found out, that people viewing our website regularly, get a broken main page, due to outdated style.css

What can I do to force them to load the new style.css without pressing f5?
Thank you!


#2

Even if I rename the style.css to style2.css, it still shows the usual website for people who don't press f5 (if i press f5, it brings me up a broken website, since there is no style.css). Somehow, the cache in the browsers never expires...


#3

and its only the css that doesnt update. for instance, if i replace an image link, it loads fine, and new images, new content. however the styling changes are absent until i press f5. and most visitors of our website, dont even think of pressing f5. which results in them receiving an outdated styling page. I introduced a new module with div classes 15 hours ago, the html and images in it load fine, but unless they press f5, they get no styling updates. so for them, the main page is broken. but they still get new articles, html, etc. I desperately need help, I've been trying to solve this for 10 hours now with no luck..


#4

This problem got "fixed" when i tried to use google pagespeed services as the CDN. It started delivering the correct style.css However, the website got slowed down with these pagespeed services (because the website is very fast with fastcgi on my linode). And when I disabled the CDN for the sake of loading times, it reverted to the old style.css and people are getting an outdated version AGAIN. Please let me know ASAP if you have any ideas


#5

@romtim

Sorry for delay in replying.

Can you please paste your ngixn config and link to tutorials you have followed from this table - http://rtcamp.com/wordpress-nginx/tutorials/ ?


#6