Failed to configure Wordpress to listen port 443


#1

Hi all,

I need your help and recommendation how to setup Wordpress (website) and wordpress admin page to listen 443.

Thanks in advance


#2

Hi mknazri,

For the easiest and most hassle free Wordpress installation you can use EasyEngine’s following command for a basic Wordress Site setup:

sudo ee site create example.com --wp

You can find EasyEngine documentation at https://easyengine.io/docs/

To setup Wordpress admin page to listen 443 you can go through our tutorials at https://easyengine.io/wordpress-nginx/tutorials/ssl/


#3

Then you must configure your DNS and stand by propagation.

Then you run ee site update example.com --le in order to add a Let‘s Encrypt certificate for free.

Then you run:

cd /var/www/domain.com/htdocs/
wp option set home https://domain.com
wp option set siteurl https://domain.com

Then you finish setting up your WP as usual.


#4

Hi ssalil,

Thanks for your info. It help me a lot!


#5

Hi janiosarmento,

Wow, let me try your way. Looks easy


#6

Hi janiosarmento,

It’s working like a charm!


#7