Excessive CPU usage


#1

Hello,

First of all thanks for this wonderful software EasyEngine. Loved the concept.

I’m having a website with almost 15-20K page views per day. I shifted this recently to Amazon EC2 C3 xlarge. OS is Ubuntu 14.04 LTS with 4 CPU and 7.5 GB Ram.

I am experiencing heavy CPU load constantly. I’m attaching two screenshots one with top command output and other giving several graph on EC2 monitor tab plus configuration of nginx and tuning primer output.

user www-data;
worker_processes 4;
worker_rlimit_nofile 100000;
pid /var/run/nginx.pid;

events {
        use epoll;
        worker_connections 16384;
        multi_accept on;
}

http {
        ##
        # EasyEngine Settings
        ##

        server_tokens off;
        reset_timedout_connection on;
        add_header X-Powered-By "EasyEngine 2.0.2";
        add_header rt-Fastcgi-Cache $upstream_cache_status;

        # Limit Request
        limit_req_status 403;
        limit_req_zone $binary_remote_addr zone=one:10m rate=1r/s;

        # Proxy Settings
        # set_real_ip_from      proxy-server-ip;
        # real_ip_header        X-Forwarded-For;

        fastcgi_read_timeout 300;
        client_max_body_size 100m;
        client_body_buffer_size 10K;
        client_header_buffer_size 1k;
        large_client_header_buffers 3 4k;


        # SSL Settings
        ssl_session_cache shared:SSL:20m;
        ssl_session_timeout 10m;
        ssl_prefer_server_ciphers on;
        ssl_ciphers HIGH:!aNULL:!MD5:!kEDH;



        ##
        # Basic Settings
        ##

        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 20;
        types_hash_max_size 2048;
        #reset_timedout_connection on;
        keepalive_requests 150;

        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

	##
        # Logging Settings
        ##
        access_log off;
        #access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        log_format rt_cache '$remote_addr $upstream_response_time $upstream_cache_status [$time_local] '
                '$http_host "$request" $status $body_bytes_sent '
                '"$http_referer" "$http_user_agent"';

        ##
        # Open File Cache
        ##

        open_file_cache max=10000 inactive=30s;
        open_file_cache_valid    40s;
        open_file_cache_min_uses 2;
        open_file_cache_errors   on;


        ##
        # Gzip Settings
        ##

        gzip on;
        gzip_disable "msie6";

        gzip_vary on;
        gzip_proxied any;
        gzip_comp_level 4;
        gzip_buffers 16 8k;
        gzip_http_version 1.1;
        gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;
        gzip_min_length 256;

        ##
        # nginx-naxsi config
        ##
        # Uncomment it if you installed nginx-naxsi
        ##

        #include /etc/nginx/naxsi_core.rules;

        ##
        # nginx-passenger config
        ##
        # Uncomment it if you installed nginx-passenger
        ##

        #passenger_root /usr;
        #passenger_ruby /usr/bin/ruby;

        ##
        # Virtual Host Configs
        ##

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;

}

#mail {
#       # See sample authentication script at:
#       # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#       # auth_http localhost/auth.php;
#       # pop3_capabilities "TOP" "USER";
#       # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#       server {
#               listen     localhost:110;
#               protocol   pop3;
#               proxy      on;
#       }
#
#       server {
#               listen     localhost:143;
#               protocol   imap;
#               proxy      on;
#       }
#}

Tuning Primer Output

-- MYSQL PERFORMANCE TUNING PRIMER --
             - By: Matthew Montgomery -

MySQL Version 5.5.38-0ubuntu0.14.04.1 x86_64

Uptime = 2 days 20 hrs 51 min 55 sec
Avg. qps = 60
Total Questions = 15116387
Threads Connected = 4

Server has been running for over 48hrs.
It should be safe to follow these recommendations

To find out more information on how each of these
runtime variables effects performance visit:
http://dev.mysql.com/doc/refman/5.5/en/server-system-variables.html
Visit http://www.mysql.com/products/enterprise/advisors.html
for info about MySQL's Enterprise Monitoring and Advisory Service

SLOW QUERIES
The slow query log is NOT enabled.
Current long_query_time = 10.000000 sec.
You have 3 out of 15116423 that take longer than 10.000000 sec. to complete
Your long_query_time seems to be fine

BINARY UPDATE LOG
The binary update log is NOT enabled.
You will not be able to do point in time recovery
See http://dev.mysql.com/doc/refman/5.5/en/point-in-time-recovery.html

WORKER THREADS
Current thread_cache_size = 8
Current threads_cached = 1
Current threads_per_sec = 0
Historic threads_per_sec = 0
Your thread_cache_size is fine

MAX CONNECTIONS
Current max_connections = 100
Current threads_connected = 7
Historic max_used_connections = 50
The number of used connections is 50% of the configured maximum.
Your max_connections variable seems to be fine.

INNODB STATUS
Current InnoDB index space = 34 M
Current InnoDB data space = 25 M
Current InnoDB buffer pool free = 36 %
Current innodb_buffer_pool_size = 128 M
Depending on how much space your innodb indexes take up it may be safe
to increase this value to up to 2 / 3 of total system memory

MEMORY USAGE
Max Memory Ever Allocated : 358 M
Configured Max Per-thread Buffers : 268 M
Configured Max Global Buffers : 224 M
Configured Max Memory Limit : 492 M
Physical Memory : 7.30 G
Max memory limit seem to be within acceptable norms

KEY BUFFER
Current MyISAM index space = 10 M
Current key_buffer_size = 16 M
Key cache miss rate is 1 : 131520
Key buffer free ratio = 28 %
Your key_buffer_size seems to be too high.
Perhaps you can use these resources elsewhere

QUERY CACHE
Query cache is enabled
Current query_cache_size = 64 M
Current query_cache_used = 58 M
Current query_cache_limit = 1 M
Current Query cache Memory fill ratio = 90.81 %
Current query_cache_min_res_unit = 4 K
However, 3246699 queries have been removed from the query cache due to lack of memory
Perhaps you should raise query_cache_size
MySQL won't cache query results that are larger than query_cache_limit in size

SORT OPERATIONS
Current sort_buffer_size = 2 M
Current read_rnd_buffer_size = 256 K
Sort buffer seems to be fine

JOINS
Current join_buffer_size = 132.00 K
You have had 0 queries where a join could not use an index properly
Your joins seem to be using indexes properly

OPEN FILES LIMIT
Current open_files_limit = 1024 files
The open_files_limit should typically be set to at least 2x-3x
that of table_cache if you have heavy MyISAM usage.
Your open_files_limit value seems to be fine

TABLE CACHE
Current table_open_cache = 400 tables
Current table_definition_cache = 400 tables
You have a total of 85 tables
You have 108 open tables.
The table_cache value seems to be fine

TEMP TABLES
Current max_heap_table_size = 16 M
Current tmp_table_size = 16 M
Of 808873 temp tables, 49% were created on disk
Perhaps you should increase your tmp_table_size and/or max_heap_table_size
to reduce the number of disk-based temporary tables
Note! BLOB and TEXT columns are not allow in memory tables.
If you are using these columns raising these values might not impact your
ratio of on disk temp tables.

TABLE SCANS
Current read_buffer_size = 128 K
Current table scan ratio = 49 : 1
read_buffer_size seems to be fine

TABLE LOCKING
Current Lock Wait ratio = 1 : 3621
You may benefit from selective use of InnoDB.
If you have long running SELECT's against MyISAM tables and perform
frequent updates consider setting 'low_priority_updates=1'
If you have a high concurrency of inserts on Dynamic row-length tables
consider setting 'concurrent_insert=ALWAYS'.

Kindly suggest me how to optimize the system.


#2

MySQL Tune:

innodb_buffer_pool_size = 512 M 
query_cache_size = 128M
open_files_limit = 10240 files
max_heap_table_size = 64M
tmp_table_size = 64 M

Restart Mysql

service mysql restart

Please provide us output of following command

ee info
ee site show example.com

#3

Hello,

First of all just confirm that location of MySql configuration file is /etc/mysql/my.cnf

I have applied the MySQL tune recommendation as suggested.

Here is the output for “ee info”

NGINX (1.6.1):
user                             www-data
worker_processes                 4
worker_connections               16384
keepalive_timeout                20
fastcgi_read_timeout             300
client_max_body_size             100m
allow                            127.0.0.1

PHP (5.5.15-4):
user                             www-data
expose_php                       Off
memory_limit                     128M
post_max_size                    100M
upload_max_filesize              100M
max_execution_time               300

Information about www.conf
ping.path                        /ping
pm.status_path                   /status
process_manager                  ondemand
pm.max_requests                  500
pm.max_children                  100
pm.start_servers                 20
pm.min_spare_servers             10
pm.max_spare_servers             30
request_terminate_timeout        300
xdebug.profiler_enable_trigger   off
listen                           127.0.0.1:9000

Information about debug.conf
ping.path                        /ping
pm.status_path                   /status
process_manager                  ondemand
pm.max_requests                  500
pm.max_children                  100
pm.start_servers                 20
pm.min_spare_servers             10
pm.max_spare_servers             30
request_terminate_timeout        300
xdebug.profiler_enable_trigger   on
listen                           127.0.0.1:9001

MySQL (5.5.38) on localhost:
port                             3306
wait_timeout                     30
interactive_timeout              60
max_used_connections             5/100
datadir                          /var/lib/mysql/
socket                           /var/run/mysqld/mysqld.sock

Here is the output for “ee site show example.com

Display NGINX configuration for 4hire.org
# WPSINGLE FastCGI NGINX CONFIGURATION

    server {
    
            server_name 4hire.org www.4hire.org;
    
            access_log   /var/log/nginx/4hire.org.access.log rt_cache;
            error_log    /var/log/nginx/4hire.org.error.log;
    
            root /var/www/4hire.org/htdocs;
            index index.php index.htm index.html;
    
            include common/wpfc.conf;
            include common/wpcommon.conf;
            include common/locations.conf;
    }

#4

All settings looks good.

Can you enabled extra kernel flags? As in given image the process rcuos/1 running multiple times.

Reference: http://ubuntuforums.org/showthread.php?t=2225218 http://stackoverflow.com/search?q=rcuos

Also keep an eye on nginx log and find out BYPASS . Refer: https://rtcamp.com/tutorials/nginx/upstream-cache-status-in-access-log/


#5

Hello,

I could not understand you by “Can you enabled extra kernel flags?” Did you said: “Can you enable extra kernel flags” or “Did you enable extra kernel flags”.

As per your link I have not touched any such setting. However, I could disable extra kernel flags. If you suggest.

nginx log for my website 4hire.org.access.log is as below after running the command

#awk '{print $3}' 4hire.org.access.log  | sort | uniq -c | sort -r
      7 UPDATING
  56690 BYPASS
 373113 MISS
   3084 -
  19051 HIT
   1539 EXPIRED
     10 STALE

Can you look into the server if I give you login credentials?


#6

You have to debug those BYPASS URL.

Its better you can contact your hosting provider related to this.

Sorry you have to hire us to debug the server issue.


#7

Hi @abhishekrukhaiyar,

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support ticket for now. Feel free to create a new support ticket if you have any queries further. :slight_smile:


#8