Everything should be done via EE?


#1

hi,

since i am rookie, i managed all complicated nginx and wordpress installations via EE, and installed multiple different WP in one server.

What i want to know is post EE period. :slight_smile: What i want to know is can i use standard commands? can i change the config files? or should i do it via EE?


#2

Hi @auludag

Yes you can use the standard commands and also change configuration files as long as your changes are correct, but its recommended to use EE as it maintains logs for actions taken by EE . If something goes wrong you can track down what went wrong and where .

Thanks,


#3

thanks for answer. is every rule defined in EE? for example: let’s say i will move my server. got a snapshot. i restored the snapshot. how can EE work in this scenario? is there a command for that?


#4

Hi @auludag

Currently EasyEngine doesn’t includes anything to handle snapshots.

Can you tell what is the use-case that you want EasyEngine to accommodate to?

Thanks.


#7

Rajdeep_Sharma hi, for example, i run apticron and it said there is a packages should be upgraded. such as:

ajenti 1.2.23.3 apache2-utils 2.2.22-13+deb7u6 base-files 7.1wheezy9 bind9-host 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 dnsutils 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 dpkg 1.16.17 dpkg-dev 1.16.17 git-man 1:1.7.10.4-1+wheezy2 grub2-common 1.99-27+deb7u3 grub-common 1.99-27+deb7u3 grub-pc 1.99-27+deb7u3 grub-pc-bin 1.99-27+deb7u3 isc-dhcp-client 4.2.2.dfsg.1-5+deb70u8 isc-dhcp-common 4.2.2.dfsg.1-5+deb70u8 libbind9-80 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 libc6 2.13-38+deb7u10 libc6-dev 2.13-38+deb7u10 libc-bin 2.13-38+deb7u10 libc-dev-bin 2.13-38+deb7u10 libdns88 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 libdpkg-perl 1.16.17 libexpat1 2.1.0-1+deb7u2 libexpat1-dev 2.1.0-1+deb7u2 libfreetype6 2.4.9-1.1+deb7u3 libgcrypt11 1.5.0-5+deb7u4 libgnutls26 2.12.20-8+deb7u5 libgssapi-krb5-2 1.10.1+dfsg-5+deb7u7 libisc84 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 libisccc80 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 libisccfg82 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 libk5crypto3 1.10.1+dfsg-5+deb7u7 libkrb5-3 1.10.1+dfsg-5+deb7u7 libkrb5support0 1.10.1+dfsg-5+deb7u7 liblcms1 1.19.dfsg2-1.2+deb7u1 libldap-2.4-2 2.4.31+really2.4.40+dfsg-1+deb8u1~bpo70+1 liblwres80 1:9.8.4.dfsg.P1-6+nmu2+deb7u9 libpng12-0 1.2.49-1+deb7u2 libssl1.0.0 1.0.1e-2+deb7u19 libssl-dev 1.0.1e-2+deb7u19 libxml2 2.8.0+dfsg1-7+wheezy5 linux-image-3.2.0-4-amd64 3.2.73-2+deb7u2 linux-libc-dev 3.2.73-2+deb7u2 locales 2.13-38+deb7u10 multiarch-support 2.13-38+deb7u10 newrelic-daemon 5.5.0.154 newrelic-php5 5.5.0.154 newrelic-php5-common 5.5.0.154 newrelic-sysmond 2.3.0.129 nginx-common 1.8.1-1ppa nginx-custom 1.8.1-1ppa ntp 1:4.2.6.p5+dfsg-2+deb7u6 ntpdate 1:4.2.6.p5+dfsg-2+deb7u6 openssh-client 1:6.0p1-4+deb7u3 openssh-server 1:6.0p1-4+deb7u3 openssl 1.0.1e-2+deb7u19 php5-cli 5.6.18-1~dotdeb+7.1 php5-common 5.6.18-1~dotdeb+7.1 php5-curl 5.6.18-1~dotdeb+7.1 php5-dev 5.6.18-1~dotdeb+7.1 php5-fpm 5.6.18-1~dotdeb+7.1 php5-gd 5.6.18-1~dotdeb+7.1 php5-imap 5.6.18-1~dotdeb+7.1 php5-mcrypt 5.6.18-1~dotdeb+7.1 php5-mysql 5.6.18-1~dotdeb+7.1 php5-readline 5.6.18-1~dotdeb+7.1 php-pear 5.6.18-1~dotdeb+7.1 redis-server 2:3.0.7-1~dotdeb+7.1 redis-tools 2:3.0.7-1~dotdeb+7.1 ssl-cert 1.0.32+deb7u1 sudo 1.8.5p2-1+nmu3+deb7u1 tzdata 2015g-0+deb7u1 unzip 6.0-8+deb7u5

when i run ee update no packages are updated. so should i update them or should i wait for EasyEngine could have some incompabilities? idk


#8

I always run the following sequence of commands:

ee update
ee stack upgrade --all
apt-get upgrade

Not all packages are handled by EE repos, AFAICT, and can be updated via ordinary apt-get.

If I’m wrong, someone please enlighten me.


#9

thank you for your reply, janiosarmento. then we will wait someone to enlighten us from RTCamp team.


#10

Hello @auludag

ee update does not upgrade any stack packages. It upgrades only EasyEngine binary codes.

To upgrade stack packages, you can follow the process given by @janiosarmento .

For more details, also refer https://easyengine.io/docs/commands/stack/#upgrade


#11

cool. thanks for answering @Prabuddha


#12