Error when I create a site


#1

Hi Friends

So far I created several sites without any problems. But suddenly, when I try to add a new site the installation stop when creating the database. This is the console transcription

Last login: Fri May 29 17:42:36 2015 from 200.117.91.224

root@hallofsolutions:~# ee site create seductionwarrior.com --wp

Running pre-update checks, please wait…

Setting up NGINX configuration [Done]

Setting up webroot [Done]

Downloading Wordpress [Done]

Setting up database

root@hallofsolutions:~#

And that’s it

Any help will be appreciated


#2

Hello @Guillermo_Varona

Will you please give me output of following command.

cat /var/log/ee/ee.log


#3

Here it is ! Thankssss !!!

2015-06-05 11:29:24,434 (DEBUG) ee : logging initialized for ‘ee’ using LoggingL ogHandler 2015-06-05 11:29:25,215 (DEBUG) ee : [’/usr/local/bin/ee’, ‘site’, ‘create’, ‘se ductionwarrior.com’, ‘–wp’] 2015-06-05 11:29:25,215 (DEBUG) ee : collecting arguments/commands for <ee.cli.c ontrollers.base.EEBaseController object at 0x7f6588ce8dd8> 2015-06-05 11:29:25,218 (DEBUG) ee : collecting arguments/commands for <ee.cli.p lugins.site.EESiteController object at 0x7f6588cf40f0> 2015-06-05 11:29:25,221 (DEBUG) ee : collecting arguments/commands for <ee.cli.p lugins.site.EESiteCreateController object at 0x7f6588cf4898> 2015-06-05 11:29:25,227 (INFO) ee : Initializing EasyEngine Database 2015-06-05 11:29:25,260 (DEBUG) ee : Setting apt_packages variable for Nginx 2015-06-05 11:29:27,787 (DEBUG) ee : Finding string SCRIPT_FILENAME to file /etc /nginx/fastcgi_params 2015-06-05 11:29:27,795 (DEBUG) ee : Setting apt_packages variable for PHP 2015-06-05 11:29:29,165 (DEBUG) ee : Setting apt_packages variable for MySQL 2015-06-05 11:29:29,165 (DEBUG) ee : Running command: mysqladmin ping 2015-06-05 11:29:29,213 (DEBUG) ee : Setting apt_packages variable for Postfix 2015-06-05 11:29:30,766 (DEBUG) ee : Setting packages variable for WP-CLI 2015-06-05 11:29:30,767 (DEBUG) ee : Running command: which wp 2015-06-05 11:29:30,783 (INFO) ee : Running pre-update checks, please wait… 2015-06-05 11:29:30,783 (DEBUG) ee : checking NGINX configuration … 2015-06-05 11:29:31,271 (INFO) ee : Setting up NGINX configuration 2015-06-05 11:29:31,272 (DEBUG) ee : loading template file /usr/lib/ee/templates /virtualconf.mustache 2015-06-05 11:29:31,275 (DEBUG) ee : Checking generated nginx conf, please wait. … 2015-06-05 11:29:31,439 (INFO) ee : [Done] 2015-06-05 11:29:31,439 (DEBUG) ee : Creating Symbolic link, Source:/etc/nginx/s ites-available/seductionwarrior.com, Dest:/etc/nginx/sites-enabled/seductionwarr ior.com 2015-06-05 11:29:31,439 (INFO) ee : Setting up webroot 2015-06-05 11:29:31,440 (DEBUG) ee : Creating Symbolic link, Source:/var/log/ngi nx/seductionwarrior.com.access.log, Dest:/var/www/seductionwarrior.com/logs/acce ss.log 2015-06-05 11:29:31,441 (DEBUG) ee : Creating Symbolic link, Source:/var/log/ngi nx/seductionwarrior.com.error.log, Dest:/var/www/seductionwarrior.com/logs/error .log 2015-06-05 11:29:31,441 (INFO) ee : [Done] 2015-06-05 11:29:31,641 (INFO) ee : Downloading Wordpress 2015-06-05 11:29:31,642 (DEBUG) ee : Changing directory to /var/www/seductionwar rior.com/htdocs/ 2015-06-05 11:29:31,642 (DEBUG) ee : Running command: wp --allow-root core downl oad 2015-06-05 11:29:32,557 (INFO) ee : [Done] 2015-06-05 11:29:32,558 (DEBUG) ee : Autofix MySQL username (ERROR 1470 (HY000)) , please wait 2015-06-05 11:29:32,558 (INFO) ee : Setting up database 2015-06-05 11:29:32,558 (DEBUG) ee : Creating database seductionwarrior_com 2015-06-05 11:29:32,561 (DEBUG) ee : 2015-06-05 11:29:32,563 (DEBUG) ee : (1045, “#28000Access denied for user ‘root’ @‘localhost’ (using password: YES)”) root@hallofsolutions:~#


#4

Hi @Guillermo_Varona

From the log it can be inferred that mysql's root credentials stored in /root/.my.cnf are not working , If you remember the working mysql root credentials you may put it in /root/.my.cnf , otherwise you should opt to [resetting mysql’s root password][1] , and plug in the new password in /root/.my.cnf

and now to verify if credentials are correct in /root/.my.cnf, run:

mysql

as root user

And now try running:

ee site create seductionwarrior.com --wp.

Thanks [1]: https://rtcamp.com/tutorials/mysql/reset-root-password/


#5

Rajdeep Thanks ! That’s is correct ! Thank you


#6

Hi @Guillermo_Varona

I hope this issue has been satisfactorily resolved, Incase of no further continuation on this issue, we will be closing the issue after a duration of 48 hours.

Feel free to create a new support topic if you have any queries further. :slight_smile:

Thanks.


#7

Yes it was solved. It can be closed. Thanks


#8